summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-13 13:32:39 -0400
committerLeo Famulari <leo@famulari.name>2018-09-13 13:32:39 -0400
commitd7639407110a584c18bb362c942eeb0933188c66 (patch)
tree8068d0737e2a65f8f9f7080b7f9fb36a74e58e2c /gnu/packages/perl-check.scm
parent36e8185667c41740786d9b2eb3672a0f8b902ed8 (diff)
parent7d1cc612938565d935c53bd7a429f41d1f048dae (diff)
downloadpatches-d7639407110a584c18bb362c942eeb0933188c66.tar
patches-d7639407110a584c18bb362c942eeb0933188c66.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 16010b441f..98b4e392c7 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -44,6 +44,27 @@
;;;
+(define-public perl-mock-config
+ (package
+ (name "perl-mock-config")
+ (version "0.03")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/Mock-Config-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "06q0xkg5cwdwafzmb9rkaa305ddv7vli9gpm6n9jnkyaaxbk9f55"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Mock-Config")
+ (synopsis "Temporarily set Config or XSConfig values")
+ (description
+ "The @code{Mock::Config} Perl module allows temporarily setting and
+overriding @code{Config} values, even for the readonly @code{XSConfig}
+implementation as used in cperl. It does not store the mocked overrides
+lexically, just dynamically.")
+ (license artistic2.0)))
+
(define-public perl-test2-bundle-extended
(package
(name "perl-test2-bundle-extended")