summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-06 15:56:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-06 15:56:24 +0200
commit12bd588346f8b2fb3709acfe0ee89d153da2db34 (patch)
tree459d8eb13a0508170ba462fe61a8b45fb55ea79f /gnu/packages/pdf.scm
parent7d5adf013127c89826e9fbe9f1a67265b3538609 (diff)
parent8e020519b45bbdb9403164bd4403f2465bac99ad (diff)
downloadpatches-12bd588346f8b2fb3709acfe0ee89d153da2db34.tar
patches-12bd588346f8b2fb3709acfe0ee89d153da2db34.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index b2d43c2b10..aaa22cce15 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -124,6 +124,36 @@
(license license:gpl2+)
(home-page "https://poppler.freedesktop.org/")))
+(define-public poppler-data
+ (package
+ (name "poppler-data")
+ (version "0.4.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://poppler.freedesktop.org/poppler-data"
+ "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04i0wgdkn5lhda8cyxd1ll4a2p41pwqrwd47n9mdpl7cx5ypx70z"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no test suite
+ #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ ;; The package only provides some data files, so there is nothing to
+ ;; build.
+ (delete 'configure)
+ (delete 'build))))
+ (synopsis "Poppler encoding files for rendering of CJK and Cyrillic text")
+ (description "This package provides optional encoding files for Poppler.
+When present, Poppler is able to correctly render CJK and Cyrillic text.")
+ (home-page (package-home-page poppler))
+ ;; See COPYING in the source distribution for more information about
+ ;; the licensing.
+ (license (list license:bsd-3
+ license:gpl2))))
+
(define-public poppler-qt4
(package (inherit poppler)
(name "poppler-qt4")