summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-25 13:42:46 -0500
committerLeo Famulari <leo@famulari.name>2017-01-26 18:56:11 -0500
commitef00f3ebaee08fe245cad6a6e0b431f88a4b7103 (patch)
tree2cf167980475561da7ebbf1cfe6c9d0e00a4ab37 /gnu/packages/pdf.scm
parent5a64a791317d98171435eff541a835ab0d3f498c (diff)
downloadpatches-ef00f3ebaee08fe245cad6a6e0b431f88a4b7103.tar
patches-ef00f3ebaee08fe245cad6a6e0b431f88a4b7103.tar.gz
gnu: mupdf, cups-filters: Incorporated grafted changes.
* gnu/packages/pdf.scm (mupdf)[replacement]: Remove field. [source]: Add 'mupdf-mujs-CVE-2016-10132.patch' and 'mupdf-mujs-CVE-2016-10133.patch'. (mupdf/fixed): Remove variable. * gnu/packages/cups.scm (cups-filters)[replacement]: Remove field. (mupdf/fixed-instead-of-mupdf),(cups-filters/fixed): Remove variables.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 2ea48e5999..d449b72eef 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -481,7 +481,6 @@ extracting content or merging files.")
(define-public mupdf
(package
(name "mupdf")
- (replacement mupdf/fixed)
(version "1.10a")
(source
(origin
@@ -491,7 +490,9 @@ extracting content or merging files.")
(sha256
(base32
"0dm8wcs8i29aibzkqkrn8kcnk4q0kd1v66pg48h5c3qqp4v1zk5a"))
- (patches (search-patches "mupdf-build-with-openjpeg-2.1.patch"))
+ (patches (search-patches "mupdf-build-with-openjpeg-2.1.patch"
+ "mupdf-mujs-CVE-2016-10132.patch"
+ "mupdf-mujs-CVE-2016-10133.patch"))
(modules '((guix build utils)))
(snippet
;; Delete all the bundled libraries except for mujs, which is
@@ -540,18 +541,6 @@ line tools for batch rendering (pdfdraw), rewriting files (pdfclean),
and examining the file structure (pdfshow).")
(license license:agpl3+)))
-(define mupdf/fixed
- (package
- (inherit mupdf)
- (source
- (origin
- (inherit (package-source mupdf))
- (patches
- (append
- (origin-patches (package-source mupdf))
- (search-patches "mupdf-mujs-CVE-2016-10132.patch"
- "mupdf-mujs-CVE-2016-10133.patch")))))))
-
(define-public qpdf
(package
(name "qpdf")