summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-13 02:03:22 -0400
committerLeo Famulari <leo@famulari.name>2016-05-13 02:08:11 -0400
commiteb74eb4199db3faac654114257996f244ec308f5 (patch)
tree9504ae968710941557be6d1edd244618eeb14448 /gnu/packages/pdf.scm
parentf10e7ef475da430afa46e0b062010952ed886694 (diff)
parente9017c98d61f305b624bacaa30e8891ec0100980 (diff)
downloadpatches-eb74eb4199db3faac654114257996f244ec308f5.tar
patches-eb74eb4199db3faac654114257996f244ec308f5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm24
1 files changed, 7 insertions, 17 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 08f7598ce7..4edf965afd 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -52,20 +52,16 @@
(define-public poppler
(package
(name "poppler")
- (version "0.37.0")
- (replacement poppler/fixed)
+ (version "0.43.0")
(source (origin
(method url-fetch)
(uri (string-append "https://poppler.freedesktop.org/poppler-"
version ".tar.xz"))
- (sha256 (base32
- "1vjvd0md8y37hlq3lsj0l01a3v3mzm572rzpn1311frvmrg9r7xq"))))
+ (sha256
+ (base32
+ "0mi4zf0pz3x3fx3ir7szz1n57nywgbpd4mp2r7mvf47f4rmf4867"))))
(build-system gnu-build-system)
- ;; FIXME: more dependencies could be added
- ;; cairo output: no (requires cairo >= 1.10.0)
- ;; qt4 wrapper: no
- ;; introspection: no
- ;; use gtk-doc: no
+ ;; FIXME:
;; use libcurl: no
(inputs `(("fontconfig" ,fontconfig)
("freetype" ,freetype)
@@ -84,7 +80,8 @@
("glib" ,glib)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("glib" ,glib "bin"))) ; glib-mkenums, etc.
+ ("glib" ,glib "bin") ; glib-mkenums, etc.
+ ("gobject-introspection" ,gobject-introspection)))
(arguments
`(#:tests? #f ; no test data provided with the tarball
#:configure-flags
@@ -108,13 +105,6 @@
(license license:gpl2+)
(home-page "http://poppler.freedesktop.org/")))
-(define poppler/fixed
- (package
- (inherit poppler)
- (source (origin
- (inherit (package-source poppler))
- (patches (search-patches "poppler-CVE-2015-8868.patch"))))))
-
(define-public poppler-qt4
(package (inherit poppler)
(name "poppler-qt4")