summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-07-04 13:23:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-05 12:26:38 +0200
commitaae8ba4746798201625a20288818b10ff58e5f1c (patch)
tree4f628284e911d463d61db27a060806ab471125fe /gnu/packages/pdf.scm
parent5082eac9579f6b8abd11fd53383c54e81d32729d (diff)
downloadpatches-aae8ba4746798201625a20288818b10ff58e5f1c.tar
patches-aae8ba4746798201625a20288818b10ff58e5f1c.tar.gz
gnu: Add libharu.
* gnu/packages/pdf.scm (libharu): New variable.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm42
1 files changed, 41 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index d46bd1f8ba..36d39856b0 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014, 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;;
@@ -28,6 +28,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages ghostscript)
@@ -154,6 +155,45 @@
Poppler PDF rendering library.")
(license license:lgpl2.1+)))
+(define-public libharu
+ (package
+ (name "libharu")
+ (version "2.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/libharu/libharu/archive/"
+ "RELEASE_"
+ (string-join (string-split version #\.) "_")
+ ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lm4v539y9cb1lvbq387j57sy7yxda3yv8b1pk8m6zazbp66i7lg"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-zlib="
+ (assoc-ref %build-inputs "zlib"))
+ (string-append "--with-png="
+ (assoc-ref %build-inputs "libpng")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'autogen
+ (lambda _ (zero? (system* "autoreconf" "-vif")))))))
+ (inputs
+ `(("zlib" ,zlib)
+ ("libpng" ,libpng)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "http://libharu.org/")
+ (synopsis "Library for generating PDF files")
+ (description
+ "libHaru is a library for generating PDF files. libHaru does not support
+reading and editing of existing PDF files.")
+ (license license:zlib)))
+
(define-public xpdf
(package
(name "xpdf")