summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-03-02 00:31:05 +0100
committerPaul van der Walt <paul@denknerd.org>2015-03-05 10:23:07 +0100
commit3e40bb829851cc33f55bcc725d9db9b7383274a7 (patch)
treeed7057cc17831948a3dc713ed7b3c14a9838e5e5 /gnu/packages/pdf.scm
parent1a8bf1dc41d37f217828b7d0f2c61707ee028111 (diff)
downloadpatches-3e40bb829851cc33f55bcc725d9db9b7383274a7.tar
patches-3e40bb829851cc33f55bcc725d9db9b7383274a7.tar.gz
gnu: Add zathura.
* gnu/packages/pdf.scm (zathura): New variable. * gnu/packages/patches/zathura-plugindir-environment-variable.patch: New file. * gnu-system.am: Add it.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 7b4f2ab055..d02a954006 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,9 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
@@ -143,6 +147,46 @@
(license license:gpl3) ; or gpl2, but not gpl2+
(home-page "http://www.foolabs.com/xpdf/")))
+(define-public zathura
+ (package
+ (name "zathura")
+ (version "0.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://pwmt.org/projects/zathura/download/zathura-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1qk5s7cyqp4l673yhma5igk9g24p5jyqyy81fdk7q7xjqlym19px"))
+ (patches
+ (list
+ (search-patch "zathura-plugindir-environment-variable.patch")))))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("gettext" ,gnu-gettext)))
+ (inputs `(("girara" ,girara)
+ ("sqlite" ,sqlite)
+ ("gtk+" ,gtk+)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "ZATHURA_PLUGIN_PATH")
+ (files '("lib/zathura")))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc" "COLOR=0")
+ #:tests? #f ; Tests fail: "Gtk cannot open display".
+ #:test-target "test"
+ #:phases
+ (alist-delete 'configure %standard-phases)))
+ (home-page "https://pwmt.org/projects/zathura/")
+ (synopsis "Lightweight keyboard-driven PDF viewer")
+ (description "Zathura is a customizable document viewer. It provides a
+minimalistic interface and an interface that mainly focuses on keyboard
+interaction.")
+ (license license:zlib)))
+
(define-public podofo
(package
(name "podofo")