summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-17 00:10:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-17 16:15:43 +0100
commit2416665ecbc931f9ed6da8d905b89da09e42ef24 (patch)
treeedc45f1be87ec008d7fe7332fbaf71a5d59ffdf8 /gnu/packages/pdf.scm
parentf0eba502a1ee564bb3b8ce6032548ec343ed49ba (diff)
downloadpatches-2416665ecbc931f9ed6da8d905b89da09e42ef24.tar
patches-2416665ecbc931f9ed6da8d905b89da09e42ef24.tar.gz
gnu: zathura, girara: Use the test-only xorg variant for tests.
* gnu/packages/gtk.scm (girara)[native-inputs]: Replace XORG-SERVER with XORG-SERVER-1.19.3. [arguments]: Add #:disallowed-references. * gnu/packages/pdf.scm (zathura)[native-inputs, arguments]: Likewise.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index aba7b974a8..2a447a9d89 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -498,7 +498,7 @@ by using the poppler rendering engine.")
;; For tests.
("check" ,check)
- ("xorg-server" ,xorg-server)))
+ ("xorg-server" ,xorg-server-1.19.3)))
(inputs `(("sqlite" ,sqlite)))
;; Listed in 'Requires.private' of 'zathura.pc'.
(propagated-inputs `(("cairo" ,cairo)
@@ -513,6 +513,7 @@ by using the poppler rendering engine.")
`(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
"CC=gcc" "COLOR=0")
#:test-target "test"
+ #:disallowed-references (,xorg-server-1.19.3)
#:phases (modify-phases %standard-phases
(delete 'configure)
(add-before 'check 'start-xserver