summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-08-15 11:47:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-08-16 09:06:08 +0300
commit0adfe0ccbebfb5b18544e3199852bb30da7548c1 (patch)
tree1b7946d7297d5f3cfde7d8f3e5fab51d433f576a /gnu/packages/pdf.scm
parent74a3c4bb6cbbcd1ed8ac1fa862a8832731a6ac44 (diff)
downloadpatches-0adfe0ccbebfb5b18544e3199852bb30da7548c1.tar
patches-0adfe0ccbebfb5b18544e3199852bb30da7548c1.tar.gz
gnu: qpdf: Use 'modify-phases'.
* gnu/packages/pdf.scm (qpdf)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 439adb90a1..b79ddebf33 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -527,17 +527,17 @@ eval '(exit $?0)' && eval 'exec perl -wS \"$0\" ${1+\"$@\"}'
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,perl)
- #:phases (alist-cons-before
- 'configure 'patch-paths
- (lambda _
- (substitute* "make/libtool.mk"
- (("SHELL=/bin/bash")
- (string-append "SHELL=" (which "bash"))))
- (substitute* (append
- '("qtest/bin/qtest-driver")
- (find-files "." "\\.test"))
- (("/usr/bin/env") (which "env"))))
- %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-paths
+ (lambda _
+ (substitute* "make/libtool.mk"
+ (("SHELL=/bin/bash")
+ (string-append "SHELL=" (which "bash"))))
+ (substitute* (append
+ '("qtest/bin/qtest-driver")
+ (find-files "." "\\.test"))
+ (("/usr/bin/env") (which "env"))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("perl" ,perl)))