summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-17 00:08:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-17 16:15:43 +0100
commitf0eba502a1ee564bb3b8ce6032548ec343ed49ba (patch)
tree33d76038a2df7b86b1253a155c4af7cd1fa036e7 /gnu/packages/pdf.scm
parent3e6b398a48aacf15f605cff4d3f492505dc134a5 (diff)
downloadpatches-f0eba502a1ee564bb3b8ce6032548ec343ed49ba.tar
patches-f0eba502a1ee564bb3b8ce6032548ec343ed49ba.tar.gz
gnu: zathura: Increase test timeouts.
* gnu/packages/pdf.scm (zathura): Export CK_DEFAULT_TIMEOUT before running tests.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 9730e6150c..aba7b974a8 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -521,6 +521,11 @@ by using the poppler rendering engine.")
(let ((xorg-server (assoc-ref inputs "xorg-server"))
(display ":1"))
(setenv "DISPLAY" display)
+
+ ;; On busy machines, tests may take longer than
+ ;; the default of four seconds.
+ (setenv "CK_DEFAULT_TIMEOUT" "20")
+
;; Don't fail due to missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
(zero? (system (string-append xorg-server "/bin/Xvfb "