summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-03-12 09:56:27 +0100
committerAndreas Enge <andreas@enge.fr>2016-03-12 09:56:27 +0100
commit8e755b1bcd377a4c475ae4cad586e6e192f20320 (patch)
treecb15f870f2f20d55db21c42d41bb5add47846e9c /gnu/packages/pdf.scm
parent0ede252b6672f8df65754a0859dddde295797660 (diff)
downloadpatches-8e755b1bcd377a4c475ae4cad586e6e192f20320.tar
patches-8e755b1bcd377a4c475ae4cad586e6e192f20320.tar.gz
gnu: mupdf: Simplify package.
* gnu/packages/pdf.scm (mupdf)[source]: Drop patch and part of snippet modifying permissions of files added by the patch. [arguments]: Use #:make-flags instead of modified build and install phases. Drop superfluous module inclusion. Use modify-phases syntax. * gnu/packages/patches/mupdf-buildsystem-fix.patch: Remove patch. * gnu-system.am (dist_patch_DATA): Unregister patch.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm34
1 files changed, 8 insertions, 26 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index a99fdd70ae..67e9beaa32 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
@@ -418,18 +418,10 @@ extracting content or merging files.")
name "-" version "-source.tar.gz"))
(sha256
(base32 "0qx51rj6alzcagcixm59rvdpm54w6syrwr4184v439jh14ryw4wq"))
- (patches
- (list (search-patch "mupdf-buildsystem-fix.patch")))
(modules '((guix build utils)))
(snippet
- '(begin
;; Don't build the bundled-in third party libraries.
- (delete-file-recursively "thirdparty")
-
- ;; Make the scripts for finding openjpeg build details executable.
- (chmod "ojp2_cppflags.sh" #o0755)
- (chmod "ojp2_ldflags.sh" #o0755)))))
-
+ '(delete-file-recursively "thirdparty"))))
(build-system gnu-build-system)
(inputs
`(("curl" ,curl)
@@ -444,22 +436,12 @@ extracting content or merging files.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(arguments
- ;; Trying to run `$ make check' results in a no rule fault.
- '(#:tests? #f
-
- #:modules ((guix build gnu-build-system)
- (guix build utils)
- (srfi srfi-1))
- #:phases (alist-replace
- 'build
- (lambda _ (zero? (system* "make" "XCFLAGS=-fpic")))
- (alist-replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (zero? (system* "make" (string-append "prefix=" out)
- "install"))))
- (alist-delete 'configure %standard-phases)))))
+ '(#:tests? #f ; no check target
+ #:make-flags (list "CC=gcc"
+ "XCFLAGS=-fpic"
+ (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
(home-page "http://mupdf.com")
(synopsis "Lightweight PDF viewer and toolkit")
(description