summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-13 21:28:01 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-13 21:28:01 +0200
commit75710da66710cef1d32053cd8f350d13057d02a7 (patch)
treeabef6a326c741b1eb18db866b2f2bacee3e5fc51 /gnu/packages/pdf.scm
parentab20c2cc33063ce783515d8ae7899ec7e2ca6f96 (diff)
parent610075f7c94c80b8321887b7ccf8bb1a7edd2b8e (diff)
downloadpatches-75710da66710cef1d32053cd8f350d13057d02a7.tar
patches-75710da66710cef1d32053cd8f350d13057d02a7.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index a7f029e235..03ed5113b1 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -25,6 +25,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
@@ -36,6 +37,7 @@
#:use-module (gnu packages lesstif)
#:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages xorg)
#:use-module (gnu packages gnome)
#:use-module (gnu packages glib)
@@ -103,6 +105,50 @@
(license license:gpl2+)
(home-page "http://poppler.freedesktop.org/")))
+(define-public poppler-qt4
+ (package (inherit poppler)
+ (name "poppler-qt4")
+ (inputs `(("qt-4" ,qt-4)
+ ,@(package-inputs poppler)))
+ (synopsis "Qt4 frontend for the Poppler PDF rendering library")))
+
+(define-public python-poppler-qt4
+ (package
+ (name "python-poppler-qt4")
+ (version "0.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/p"
+ "/python-poppler-qt4/python-poppler-qt4-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0x63niylkk4q3h3ay8zrk3m1xiik0x3hlr4gvj7kswx48qi1vb99"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'unpack 'patch-poppler-include-paths
+ (lambda _
+ (substitute* (find-files "." "poppler-.*\\.sip")
+ (("qt4/poppler-.*\\.h" header)
+ (string-append "poppler/" header)))
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("python-sip" ,python-sip)
+ ("python-pyqt-4" ,python-pyqt-4)
+ ("poppler-qt4" ,poppler-qt4)))
+ (home-page "https://pypi.python.org/pypi/python-poppler-qt4")
+ (synopsis "Python bindings for Poppler-Qt4")
+ (description
+ "This package provides Python bindings for the Qt4 interface of the
+Poppler PDF rendering library.")
+ (license license:lgpl2.1+)))
+
(define-public xpdf
(package
(name "xpdf")