summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-10-17 16:47:12 -0400
committerMark H Weaver <mhw@netris.org>2016-10-17 16:47:12 -0400
commitdcaf70897a0bad38a4638a2905aaa3c46b1f1402 (patch)
tree439c42bf27972a628ebc0fef11a63b9130ca19a5 /gnu/packages/pdf.scm
parentbf62b8ff79f9d60136996b8251b6475965cf4994 (diff)
parent040b6299d505c034b4960c335434a500ae2f8187 (diff)
downloadpatches-dcaf70897a0bad38a4638a2905aaa3c46b1f1402.tar
patches-dcaf70897a0bad38a4638a2905aaa3c46b1f1402.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 6f779feccb..8bfe2c1a89 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -8,6 +8,7 @@
;;; Coypright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Coypright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Coypright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Coypright © 2016 Julien Lepiller <julien@lepiller.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,6 +47,11 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages backup)
#:use-module (gnu packages lesstif)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages photo)
#:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt)
@@ -697,3 +703,51 @@ such as smooth alpha-blended slide transitions. It provides additional tools
such as zooming, highlighting an area of the screen, and a tool to navigate
the PDF pages.")
(license license:gpl2)))
+
+(define-public fbida
+ (package
+ (name "fbida")
+ (version "2.12")
+ (home-page "https://www.kraxel.org/blog/linux/fbida/")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.kraxel.org/releases/fbida/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0bw224vb7jh0lrqaf4jgxk48xglvxs674qcpj5y0axyfbh896cfk"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-cons-after
+ 'unpack 'patch-ldconfig
+ (lambda _
+ (substitute* "mk/Autoconf.mk"
+ (("/sbin/ldconfig -p") "echo lib")) #t)
+ (alist-delete 'configure %standard-phases))
+ #:tests? #f
+ #:make-flags (list "CC=gcc"
+ (string-append "prefix=" (assoc-ref %outputs "out")))))
+ (inputs `(("libjpeg" ,libjpeg)
+ ("curl" ,curl)
+ ("libtiff" ,libtiff)
+ ("libudev" ,eudev)
+ ("libwebp" ,libwebp)
+ ("libdrm" ,libdrm)
+ ("imagemagick" ,imagemagick)
+ ("giflib" ,giflib)
+ ("glib" ,glib)
+ ("cairo-xcb" ,cairo-xcb)
+ ("freetype" ,freetype)
+ ("fontconfig" ,fontconfig)
+ ("libexif" ,libexif)
+ ("mesa" ,mesa)
+ ("libepoxy" ,libepoxy)
+ ("libpng" ,libpng)
+ ("poppler" ,poppler)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "Framebuffer and drm-based image viewer")
+ (description
+ "fbida contains a few applications for viewing and editing images on
+the framebuffer.")
+
+ (license license:gpl2+)))