summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-19 20:33:34 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-01 07:13:49 +0200
commit06dbfb5d197db7502ed65c1019e96f3f02c34b7a (patch)
tree7832e915cca6e3e78aa31cef04c105738a877329 /gnu/packages/pdf.scm
parent02fcc6f240946cfd51bfe548e260b2f3150f0ab4 (diff)
downloadpatches-06dbfb5d197db7502ed65c1019e96f3f02c34b7a.tar
patches-06dbfb5d197db7502ed65c1019e96f3f02c34b7a.tar.gz
gnu: zathura-ps: Update to 0.2.6.
* gnu/packages/pdf.scm (zathura-ps): Update to 0.2.6. [build-system]: Switch to the Meson build system. [arguments]: Trim accordingly. Add a new ‘patch-plugin-directory’ phase.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm24
1 files changed, 15 insertions, 9 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 1054bc2fda..77d78bb805 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -349,26 +349,32 @@ using libarchive.")
(define-public zathura-ps
(package
(name "zathura-ps")
- (version "0.2.5")
+ (version "0.2.6")
(source (origin
(method url-fetch)
(uri
(string-append "https://pwmt.org/projects/zathura-ps/download/zathura-ps-"
- version ".tar.gz"))
+ version ".tar.xz"))
(sha256
(base32
- "1x4knqja8pw2a5cb3y2209nr3iddj1z8nwasy48v5nprj61fdxqj"))))
+ "0wygq89nyjrjnsq7vbpidqdsirjm6iq4w2rijzwpk2f83ys8bc3y"))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("libspectre" ,libspectre)
("zathura" ,zathura)))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(arguments
- `(#:make-flags (list (string-append "PREFIX=" %output)
- (string-append "PLUGINDIR=" %output "/lib/zathura")
- "CC=gcc")
- #:tests? #f ; Package does not contain tests.
+ `(#:tests? #f ; package does not contain tests
#:phases
- (modify-phases %standard-phases (delete 'configure))))
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-plugin-directory
+ ;; Something of a regression in 0.2.6: the new Meson build system
+ ;; now hard-codes an incorrect plugin directory. Fix it.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "meson.build"
+ (("(install_dir:).*" _ key)
+ (string-append key
+ "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
+ #t)))))
(home-page "https://pwmt.org/projects/zathura-ps/")
(synopsis "PS support for zathura (libspectre backend)")
(description "The zathura-ps plugin adds PS support to zathura