summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-02-24 20:09:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-24 21:26:58 +0100
commit7ad608e49d41447e106de4827336c606d4e8d4c8 (patch)
tree4af1fc71bd831059cf6307659d2049feef6238dd /gnu/packages/pdf.scm
parent6d5e7ef3ae45584fd4f6e1c0374ceabf1c826b3c (diff)
downloadpatches-7ad608e49d41447e106de4827336c606d4e8d4c8.tar
patches-7ad608e49d41447e106de4827336c606d4e8d4c8.tar.gz
gnu: Add Xournal.
* gnu/packages/pdf.scm (xournal): New variable.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 1ce4c0cb13..7b4f2ab055 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +33,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages openssl)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages lua)
@@ -281,3 +282,31 @@ manipulate the list of pages in a PDF file. It is not a PDF viewer or a
program capable of converting PDF into other formats.")
(license license:clarified-artistic)
(home-page "http://qpdf.sourceforge.net/")))
+
+(define-public xournal
+ (package
+ (name "xournal")
+ (version "0.4.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xournal/xournal-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0c7gjcqhygiyp0ypaipdaxgkbivg6q45vhsj8v5jsi9nh6iqff13"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gtk" ,gtk+-2)
+ ("pango" ,pango)
+ ("poppler" ,poppler)
+ ("glib" ,glib)
+ ("libgnomecanvas" ,libgnomecanvas)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://xournal.sourceforge.net/")
+ (synopsis "Notetaking using a stylus")
+ (description
+ "Xournal is an application for notetaking, sketching, keeping a journal
+using a stylus.")
+ (license license:gpl2+)))