summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-19 16:53:01 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-19 16:53:01 +0200
commit7abe35febe4234609e14e169b6fcc0cbaf4c7119 (patch)
tree5a8307a28e0c0a6aeab21ce8b9d3487229522588 /gnu/packages/pdf.scm
parent457ded48c54ba04489cb871d3ec6bda0c59bead7 (diff)
parent5c10d55206a4f7a9b932ff08512a4f50c1db35be (diff)
downloadpatches-7abe35febe4234609e14e169b6fcc0cbaf4c7119.tar
patches-7abe35febe4234609e14e169b6fcc0cbaf4c7119.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index bb3a26525f..8ccb133e1f 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -822,7 +822,7 @@ using a stylus.")
(define-public xournalpp
(package
(name "xournalpp")
- (version "1.0.17")
+ (version "1.0.18")
(source
(origin
(method git-fetch)
@@ -831,7 +831,7 @@ using a stylus.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0xw2mcgnm4sa9hrhfgp669lfypw97drxjmz5w8i5whaprpvmkxzw"))))
+ (base32 "0a9ygbmd4dwgck3k8wsrm2grynqa0adb12wwspzmzvpisbadffjy"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DENABLE_CPPUNIT=ON") ;enable tests
@@ -844,11 +844,6 @@ using a stylus.")
(modify-phases %standard-phases
(add-after 'unpack 'fix-permissions-on-po-files
(lambda _
- ;; Always generate translations. A recent upstream patch
- ;; disabled it.
- (substitute* "po/CMakeLists.txt"
- (("gettext_create_translations \\(\"\\$\\{potfile\\}\"\\)")
- "gettext_create_translations (\"${potfile}\" ALL)"))
;; Make sure 'msgmerge' can modify the PO files.
(for-each (lambda (po) (chmod po #o666))
(find-files "." "\\.po$"))
@@ -857,7 +852,6 @@ using a stylus.")
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
`(("cppunit" ,cppunit)
- ("gcc" ,gcc-8) ;requires gcc 8+
("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
(inputs