summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-19 20:36:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-20 21:53:51 +0100
commitae3909eb4c36255834b5780ad8aa29055181c964 (patch)
tree84a118ec6b477bdbeb3d2f6ef54fcfdeb975c01f /gnu/packages/patches
parent544ea9c2df82bd737319b29a0e4f9b2f39c6321a (diff)
downloadpatches-ae3909eb4c36255834b5780ad8aa29055181c964.tar
patches-ae3909eb4c36255834b5780ad8aa29055181c964.tar.gz
gnu: python-parameterized: Update to 0.7.1.
* gnu/packages/patches/python2-parameterized-docstring-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/check.scm (python-parameterized): Update to 0.7.1. [arguments]: Remove #:tests?. Add #:phases to override 'check' phase. [native-inputs]: Add PYTHON-MOCK and PYTHON-NOSE. [properties]: New field. (python2-parameterized)[source](patches): New field.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python2-parameterized-docstring-test.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/python2-parameterized-docstring-test.patch b/gnu/packages/patches/python2-parameterized-docstring-test.patch
new file mode 100644
index 0000000000..14691e1904
--- /dev/null
+++ b/gnu/packages/patches/python2-parameterized-docstring-test.patch
@@ -0,0 +1,18 @@
+Skip unicode docstring test, required when running on Python 2.
+
+See <https://github.com/wolever/parameterized/issues/44>.
+
+--- a/parameterized/test.py
++++ b/parameterized/test.py
+@@ -284,11 +284,6 @@
+ " More" %(foo, )
+ )
+
+- @parameterized.expand([param("foo")])
+- def test_unicode_docstring(self, foo):
+- u"""Döcumentation."""
+- self._assert_docstring(u"Döcumentation [with foo=%r]." %(foo, ))
+-
+ @parameterized.expand([param("foo", )])
+ def test_default_values_get_correct_value(self, foo, bar=12):
+ """Documentation"""