summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-09 17:31:00 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-10 18:16:39 +0100
commit98619142b8c54287136216d0008871f9170a1808 (patch)
treec478f5e36aea845eadf97542b2e8469a45a0d7b4 /gnu/packages/patches
parent0e20e2c3871075a8fa117e2139f9ac494e08f0de (diff)
downloadpatches-98619142b8c54287136216d0008871f9170a1808.tar
patches-98619142b8c54287136216d0008871f9170a1808.tar.gz
gnu: guile-next: Update to 3.0.1 with bug-fix for crash.
* gnu/packages/guile.scm (guile-3.0): Update to 3.0.1 with "guile-3.0-crash.patch". * gnu/packages/patches/guile-3.0-crash.patch: New file. * gnu/local.mk (dist_patch_DATA): Use it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/guile-3.0-crash.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-3.0-crash.patch b/gnu/packages/patches/guile-3.0-crash.patch
new file mode 100644
index 0000000000..510834ab57
--- /dev/null
+++ b/gnu/packages/patches/guile-3.0-crash.patch
@@ -0,0 +1,17 @@
+Fix crash due to: <https://issues.guix.gnu.org/issue/39266>.
+
+diff --git a/libguile/struct.c b/libguile/struct.c
+index 3dbcc71d4..ddcbe46d2 100644
+--- a/libguile/struct.c
++++ b/libguile/struct.c
+@@ -139,7 +139,9 @@ set_vtable_access_fields (SCM vtable)
+ nfields = len / 2;
+
+ bitmask_size = (nfields + 31U) / 32U;
+- unboxed_fields = scm_gc_malloc_pointerless (bitmask_size, "unboxed fields");
++ unboxed_fields =
++ scm_gc_malloc_pointerless (bitmask_size * sizeof (*unboxed_fields),
++ "unboxed fields");
+ memset (unboxed_fields, 0, bitmask_size * sizeof(*unboxed_fields));
+
+ /* Update FLAGS according to LAYOUT. */