summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-04 20:12:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-04 20:12:41 +0100
commit33b59c1a3edbb81735e8d4e977b107f3ba1c2f9f (patch)
tree79ee86a29266d0a32ec0d0aa790ee5904b1098b8 /gnu/packages/patches
parent936aa05209402dd399869ffae188db5dd5f67d69 (diff)
parentd733a469d74f74734825f1ce777956fb4cac5534 (diff)
downloadpatches-33b59c1a3edbb81735e8d4e977b107f3ba1c2f9f.tar
patches-33b59c1a3edbb81735e8d4e977b107f3ba1c2f9f.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gstreamer-buffer-reset-offset.patch59
-rw-r--r--gnu/packages/patches/kinit-kdeinit-extra_libs.patch4
-rw-r--r--gnu/packages/patches/kpmcore-fix-tests.patch30
-rw-r--r--gnu/packages/patches/kpmcore-remove-broken-test.patch139
-rw-r--r--gnu/packages/patches/mesa-timespec-test-32bit.patch17
-rw-r--r--gnu/packages/patches/orc-typedef-enum.patch17
-rw-r--r--gnu/packages/patches/pyqt-unbundled-qt.patch19
-rw-r--r--gnu/packages/patches/qtbase-old-kernel.patch25
-rw-r--r--gnu/packages/patches/sdl2-mesa-compat.patch21
9 files changed, 244 insertions, 87 deletions
diff --git a/gnu/packages/patches/gstreamer-buffer-reset-offset.patch b/gnu/packages/patches/gstreamer-buffer-reset-offset.patch
deleted file mode 100644
index 024892a60f..0000000000
--- a/gnu/packages/patches/gstreamer-buffer-reset-offset.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-Fix a buffer offset problem in GStreamer 1.16. Initially reported by Mark H.
-Weaver in <https://lists.gnu.org/archive/html/guix-devel/2019-06/msg00140.html>.
-
-See also <https://gitlab.freedesktop.org/gstreamer/gstreamer/issues/316>.
-
-From 1734c9fc1a4f99b165383ae1eb02f04e0844a00c Mon Sep 17 00:00:00 2001
-From: Nicolas Dufresne <nicolas.dufresne@collabora.com>
-Date: Sat, 29 Jun 2019 09:22:05 -0400
-Subject: [PATCH] bufferpool: Fix the buffer size reset code
-
-The offset in gst_buffer_resize() is additive. So to move back the
-offset to zero, we need to pass the opposite of the current offset. This
-was raised through the related unit test failingon 32bit as on 64bit
-the alignment padding was enough to hide the issue. The test was
-modified to also fail on 64bit. This patch will remove spurious
-assertions like:
-
- assertion 'bufmax >= bufoffs + offset + size' failed
-
-Fixes #316
----
- gst/gstbufferpool.c | 7 +++++--
- tests/check/gst/gstbufferpool.c | 2 +-
- 2 files changed, 6 insertions(+), 3 deletions(-)
-
-diff --git a/gst/gstbufferpool.c b/gst/gstbufferpool.c
-index e5c7a5872..619860e63 100644
---- a/gst/gstbufferpool.c
-+++ b/gst/gstbufferpool.c
-@@ -1222,8 +1222,11 @@ default_reset_buffer (GstBufferPool * pool, GstBuffer * buffer)
- GST_BUFFER_OFFSET_END (buffer) = GST_BUFFER_OFFSET_NONE;
-
- /* if the memory is intact reset the size to the full size */
-- if (!GST_BUFFER_FLAG_IS_SET (buffer, GST_BUFFER_FLAG_TAG_MEMORY))
-- gst_buffer_resize (buffer, 0, pool->priv->size);
-+ if (!GST_BUFFER_FLAG_IS_SET (buffer, GST_BUFFER_FLAG_TAG_MEMORY)) {
-+ gsize offset;
-+ gst_buffer_get_sizes (buffer, &offset, NULL);
-+ gst_buffer_resize (buffer, -offset, pool->priv->size);
-+ }
-
- /* remove all metadata without the POOLED flag */
- gst_buffer_foreach_meta (buffer, remove_meta_unpooled, pool);
-diff --git a/tests/check/gst/gstbufferpool.c b/tests/check/gst/gstbufferpool.c
-index f0c3c8d8e..dd9b2dc03 100644
---- a/tests/check/gst/gstbufferpool.c
-+++ b/tests/check/gst/gstbufferpool.c
-@@ -190,7 +190,7 @@ GST_START_TEST (test_buffer_modify_discard)
- gst_buffer_pool_acquire_buffer (pool, &buf, NULL);
- buffer_track_destroy (buf, &dcount);
- /* do resize, as we didn't modify the memory, pool should reuse this buffer */
-- gst_buffer_resize (buf, 5, 2);
-+ gst_buffer_resize (buf, 8, 2);
- gst_buffer_unref (buf);
-
- /* buffer should've gone back into pool */
---
-2.22.0
-
diff --git a/gnu/packages/patches/kinit-kdeinit-extra_libs.patch b/gnu/packages/patches/kinit-kdeinit-extra_libs.patch
index 8dcd4d3e95..c3c4ce1161 100644
--- a/gnu/packages/patches/kinit-kdeinit-extra_libs.patch
+++ b/gnu/packages/patches/kinit-kdeinit-extra_libs.patch
@@ -8,15 +8,13 @@ pkgs/development/libraries/kde-frameworks/kinit/kdeinit-extra_libs.patch
===================================================================
--- kinit-5.32.0/src/kdeinit/kinit-5.32.0/src/kdeinit/.orig
+++ kinit-5.32.0/src/kdeinit/kinit.cpp
-@@ -96,11 +96,9 @@
+@@ -96,9 +96,9 @@
"libKF5Parts.5.dylib",
"libKF5Plasma.5.dylib"
#else
- "libKF5KIOCore.so.5",
- "libKF5Parts.so.5",
--//#ifdef __KDE_HAVE_GCC_VISIBILITY // Removed for KF5, we'll see.
- "libKF5Plasma.so.5"
--//#endif
+ "GUIX_PKGS_KF5_KIO/lib/libKF5KIOCore.so.5",
+ "GUIX_PKGS_KF5_PARTS/lib/libKF5Parts.so.5",
+ "GUIX_PKGS_KF5_PLASMA/lib/libKF5Plasma.so.5"
diff --git a/gnu/packages/patches/kpmcore-fix-tests.patch b/gnu/packages/patches/kpmcore-fix-tests.patch
new file mode 100644
index 0000000000..12043abe72
--- /dev/null
+++ b/gnu/packages/patches/kpmcore-fix-tests.patch
@@ -0,0 +1,30 @@
+Git commit c02d59aa6d314678cef9683f96b28e2a1abd82b7 by Andrius Štikonas, on behalf of Hartmut Goebel.
+Committed on 07/11/2019 at 22:16.
+Pushed by stikonas into branch '4.0'.
+
+Fix test for kpmcore: stop helper only if formerly started.
+
+See https://bugs.kde.org/413851 and https://phabricator.kde.org/D25161
+
+diff --git a/src/util/externalcommand.cpp b/src/util/externalcommand.cpp
+--- a/src/util/externalcommand.cpp
++++ b/src/util/externalcommand.cpp
+@@ -433,14 +433,17 @@
+
+ void ExternalCommand::stopHelper()
+ {
++ if (!helperStarted)
++ return;
+ auto *interface = new org::kde::kpmcore::externalcommand(QStringLiteral("org.kde.kpmcore.externalcommand"),
+ QStringLiteral("/Helper"), QDBusConnection::systemBus());
+ QByteArray request;
+ const quint64 nonce = interface->getNonce();
+ request.setNum(nonce);
+ QByteArray hash = QCryptographicHash::hash(request, QCryptographicHash::Sha512);
+ interface->exit(privateKey->signMessage(hash, QCA::EMSA3_Raw), nonce);
+
++ helperStarted = false;
+ delete privateKey;
+ delete init;
+ }
+
diff --git a/gnu/packages/patches/kpmcore-remove-broken-test.patch b/gnu/packages/patches/kpmcore-remove-broken-test.patch
new file mode 100644
index 0000000000..d02cca7883
--- /dev/null
+++ b/gnu/packages/patches/kpmcore-remove-broken-test.patch
@@ -0,0 +1,139 @@
+From c9a08a593bac8b8610a647db118fea6f2958156d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andrius=20=C5=A0tikonas?= <andrius@stikonas.eu>
+Date: Thu, 7 Nov 2019 22:12:00 +0000
+Subject: [PATCH] Remove broken smart unit test.
+
+BUG: 413853
+---
+ test/CMakeLists.txt | 9 ----
+ test/testsmart.cpp | 102 --------------------------------------------
+ 2 files changed, 111 deletions(-)
+ delete mode 100644 test/testsmart.cpp
+
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index 67f63a2..6a300d3 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -53,12 +53,3 @@ find_package (Threads)
+ # Execute external commands as root
+ kpm_test(testexternalcommand testexternalcommand.cpp)
+ add_test(NAME testexternalcommand COMMAND testexternalcommand ${BACKEND})
+-
+-# Including SMART files reference
+-set(SMARTPARSER ${CMAKE_SOURCE_DIR}/src/core/smartdiskinformation.cpp
+- ${CMAKE_SOURCE_DIR}/src/core/smartattributeparseddata.cpp
+- ${CMAKE_SOURCE_DIR}/src/core/smartparser.cpp)
+-
+-# Test SMART support
+-kpm_test(testsmart testsmart.cpp ${SMARTPARSER})
+-add_test(NAME testsmart COMMAND testsmart ${BACKEND})
+diff --git a/test/testsmart.cpp b/test/testsmart.cpp
+deleted file mode 100644
+index 2236af7..0000000
+--- a/test/testsmart.cpp
++++ /dev/null
+@@ -1,102 +0,0 @@
+-#include "helpers.h"
+-
+-#include "util/externalcommand.h"
+-#include "backend/corebackend.h"
+-#include "backend/corebackendmanager.h"
+-#include "core/smartstatus.h"
+-#include "core/smartparser.h"
+-
+-#include <QCoreApplication>
+-#include <QDebug>
+-
+-static QString getDefaultDevicePath();
+-static bool testSmartStatus();
+-static bool testSmartParser();
+-
+-int main(int argc, char **argv)
+-{
+- QCoreApplication app(argc, argv);
+-
+- KPMCoreInitializer i;
+-
+- if (argc == 2)
+- i = KPMCoreInitializer(argv[1]);
+-
+- if (!i.isValid())
+- return 1;
+-
+- CoreBackend *backend = CoreBackendManager::self()->backend();
+-
+- if (!backend)
+- {
+- qWarning() << "Couldn't get backend.";
+- return 1;
+- }
+-
+- if (!testSmartStatus() || !testSmartParser())
+- return 1;
+-
+- return app.exec();
+-}
+-
+-static QString getDefaultDevicePath()
+-{
+- // Getting default home partition using 'df -P /home | awk 'END{print $1}'' command
+- ExternalCommand command(QStringLiteral("df"), { QStringLiteral("-P"), QStringLiteral("/home"), QStringLiteral("|"),
+- QStringLiteral("awk"), QStringLiteral("\'END{print $1}\'") });
+-
+- if (command.run() && command.exitCode() == 0) {
+- QString output = command.output();
+- return output;
+- }
+-
+- return QString();
+-}
+-
+-static bool testSmartStatus()
+-{
+- QString devicePath = getDefaultDevicePath();
+-
+- SmartStatus smart(devicePath);
+-
+- if (smart.devicePath() != devicePath)
+- return false;
+-
+- if (!smart.status())
+- return false;
+-
+- if (smart.modelName() == QString())
+- return false;
+-
+- if (smart.firmware() == QString())
+- return false;
+-
+- if (smart.serial() == QString())
+- return false;
+-
+- if (smart.selfTestStatus() != SmartStatus::SelfTestStatus::Success)
+- return false;
+-
+- if (!smart.isValid())
+- return false;
+-
+- return true;
+-}
+-
+-static bool testSmartParser()
+-{
+- QString devicePath = getDefaultDevicePath();
+-
+- SmartParser parser(devicePath);
+-
+- if (!parser.init())
+- return false;
+-
+- if (parser.devicePath() != devicePath)
+- return false;
+-
+- if (!parser.diskInformation())
+- return false;
+-
+- return true;
+-}
+--
+2.17.1
diff --git a/gnu/packages/patches/mesa-timespec-test-32bit.patch b/gnu/packages/patches/mesa-timespec-test-32bit.patch
new file mode 100644
index 0000000000..3e4890f3a4
--- /dev/null
+++ b/gnu/packages/patches/mesa-timespec-test-32bit.patch
@@ -0,0 +1,17 @@
+Fix a test failure on 32-bit systems.
+
+Taken from upstream:
+https://gitlab.freedesktop.org/mesa/mesa/commit/dd1dba80b9ee74ec8b90761285a8262e374bf8ef
+
+diff --git a/src/util/tests/timespec/timespec_test.cpp b/src/util/tests/timespec/timespec_test.cpp
+--- a/src/util/tests/timespec/timespec_test.cpp
++++ b/src/util/tests/timespec/timespec_test.cpp
+@@ -206,7 +206,7 @@ TEST(timespec_test, timespec_from_nsec)
+
+ timespec_from_nsec(&a, UINT64_MAX);
+ EXPECT_EQ(a.tv_nsec, UINT64_MAX % NSEC_PER_SEC);
+- EXPECT_EQ(a.tv_sec, UINT64_MAX / NSEC_PER_SEC);
++ EXPECT_EQ(a.tv_sec, (time_t)(UINT64_MAX / NSEC_PER_SEC));
+ }
+
+ TEST(timespec_test, timespec_from_usec)
diff --git a/gnu/packages/patches/orc-typedef-enum.patch b/gnu/packages/patches/orc-typedef-enum.patch
new file mode 100644
index 0000000000..207bf32ba9
--- /dev/null
+++ b/gnu/packages/patches/orc-typedef-enum.patch
@@ -0,0 +1,17 @@
+Orc 0.4.30 has a bug that causes duplicate symbols due to a missing typedef.
+
+Taken from upstream:
+https://gitlab.freedesktop.org/gstreamer/orc/merge_requests/32
+
+diff --git a/orc/orctarget.h b/orc/orctarget.h
+--- a/orc/orctarget.h
++++ b/orc/orctarget.h
+@@ -19,7 +19,7 @@ enum {
+ ORC_TARGET_FAST_DENORMAL = (1<<31)
+ };
+
+-enum {
++typedef enum {
+ ORC_TARGET_POWERPC_64BIT = (1<<0),
+ ORC_TARGET_POWERPC_LE = (1<<1),
+ ORC_TARGET_POWERPC_ALTIVEC = (1<<2),
diff --git a/gnu/packages/patches/pyqt-unbundled-qt.patch b/gnu/packages/patches/pyqt-unbundled-qt.patch
new file mode 100644
index 0000000000..5c91ed031c
--- /dev/null
+++ b/gnu/packages/patches/pyqt-unbundled-qt.patch
@@ -0,0 +1,19 @@
+Remove test for bundled Qt which breaks dependent applications. This has
+been fixed in 5.13.
+
+Taken from Arch Linux:
+https://git.archlinux.org/svntogit/packages.git/tree/trunk/python2-pyqt5-crash-fix.patch?h=packages/pyqt5&id=3e56e11d1fd7b1eac8242ce64c58db2bd9acba20
+
+diff -ur PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in
+--- PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in 2019-06-25 14:41:02.000000000 +0200
++++ PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in 2019-07-01 17:06:34.882644535 +0200
+@@ -151,8 +151,4 @@
+ // initialised first (at least for Windows) and this is the only way to
+ // guarantee things are done in the right order.
+ PyQtSlotProxy::mutex = new QMutex(QMutex::Recursive);
+-
+- // Load the embedded qt.conf file if there is a bundled copy of Qt.
+- if (!qpycore_qt_conf())
+- Py_FatalError("PyQt5.QtCore: Unable to embed qt.conf");
+ }
+
diff --git a/gnu/packages/patches/qtbase-old-kernel.patch b/gnu/packages/patches/qtbase-old-kernel.patch
deleted file mode 100644
index aa26fb6c4f..0000000000
--- a/gnu/packages/patches/qtbase-old-kernel.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-https://672856.bugs.gentoo.org/attachment.cgi?id=557978
-https://bugs.gentoo.org/672856
-
-The patch fixes building qtbase with linux kernels < 4.11.
-See bug #34431.
-
-diff -Naurp a/src/corelib/global/minimum-linux_p.h b/src/corelib/global/minimum-linux_p.h
---- a/src/corelib/global/minimum-linux_p.h 2018-11-25 15:51:11.000000000 +0300
-+++ b/src/corelib/global/minimum-linux_p.h 2018-12-17 13:25:38.176823753 +0300
-@@ -75,14 +75,9 @@ QT_BEGIN_NAMESPACE
- * - accept4 2.6.28
- * - renameat2 3.16 QT_CONFIG(renameat2)
- * - getrandom 3.17 QT_CONFIG(getentropy)
-- * - statx 4.11 QT_CONFIG(statx)
- */
-
--#if QT_CONFIG(statx)
--# define MINLINUX_MAJOR 4
--# define MINLINUX_MINOR 11
--# define MINLINUX_PATCH 0
--#elif QT_CONFIG(getentropy)
-+#if QT_CONFIG(getentropy)
- # define MINLINUX_MAJOR 3
- # define MINLINUX_MINOR 17
- # define MINLINUX_PATCH 0
diff --git a/gnu/packages/patches/sdl2-mesa-compat.patch b/gnu/packages/patches/sdl2-mesa-compat.patch
new file mode 100644
index 0000000000..8182e582e7
--- /dev/null
+++ b/gnu/packages/patches/sdl2-mesa-compat.patch
@@ -0,0 +1,21 @@
+Do not include GLES header when OpenGL headers are already included.
+
+Taken from upstream:
+https://hg.libsdl.org/SDL/rev/369b01006eb2
+
+diff -r 4cbaffd0083b -r 369b01006eb2 src/video/SDL_video.c
+--- a/src/video/SDL_video.c Fri Oct 11 06:18:24 2019 +0200
++++ b/src/video/SDL_video.c Sat Oct 12 18:47:56 2019 +0200
+@@ -37,9 +37,9 @@
+ #include "SDL_opengl.h"
+ #endif /* SDL_VIDEO_OPENGL */
+
+-#if SDL_VIDEO_OPENGL_ES
++#if SDL_VIDEO_OPENGL_ES && !SDL_VIDEO_OPENGL
+ #include "SDL_opengles.h"
+-#endif /* SDL_VIDEO_OPENGL_ES */
++#endif /* SDL_VIDEO_OPENGL_ES && !SDL_VIDEO_OPENGL */
+
+ /* GL and GLES2 headers conflict on Linux 32 bits */
+ #if SDL_VIDEO_OPENGL_ES2 && !SDL_VIDEO_OPENGL
+