summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/sdl2-mesa-compat.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-15 18:09:14 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-15 18:09:14 +0200
commitc43626131222b7b62d8cb6f5fe90c072d440df26 (patch)
tree40d459883846bd7fd99bc5259c79db42f3553c86 /gnu/packages/patches/sdl2-mesa-compat.patch
parent2737c7fe8a24f18a7f1495781dbe34c4b8af5bed (diff)
downloadpatches-c43626131222b7b62d8cb6f5fe90c072d440df26.tar
patches-c43626131222b7b62d8cb6f5fe90c072d440df26.tar.gz
gnu: sdl2: Fix build on 32-bit architectures.
* gnu/packages/patches/sdl2-mesa-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/sdl.scm (sdl2)[source](patches): New field.
Diffstat (limited to 'gnu/packages/patches/sdl2-mesa-compat.patch')
-rw-r--r--gnu/packages/patches/sdl2-mesa-compat.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/sdl2-mesa-compat.patch b/gnu/packages/patches/sdl2-mesa-compat.patch
new file mode 100644
index 0000000000..8182e582e7
--- /dev/null
+++ b/gnu/packages/patches/sdl2-mesa-compat.patch
@@ -0,0 +1,21 @@
+Do not include GLES header when OpenGL headers are already included.
+
+Taken from upstream:
+https://hg.libsdl.org/SDL/rev/369b01006eb2
+
+diff -r 4cbaffd0083b -r 369b01006eb2 src/video/SDL_video.c
+--- a/src/video/SDL_video.c Fri Oct 11 06:18:24 2019 +0200
++++ b/src/video/SDL_video.c Sat Oct 12 18:47:56 2019 +0200
+@@ -37,9 +37,9 @@
+ #include "SDL_opengl.h"
+ #endif /* SDL_VIDEO_OPENGL */
+
+-#if SDL_VIDEO_OPENGL_ES
++#if SDL_VIDEO_OPENGL_ES && !SDL_VIDEO_OPENGL
+ #include "SDL_opengles.h"
+-#endif /* SDL_VIDEO_OPENGL_ES */
++#endif /* SDL_VIDEO_OPENGL_ES && !SDL_VIDEO_OPENGL */
+
+ /* GL and GLES2 headers conflict on Linux 32 bits */
+ #if SDL_VIDEO_OPENGL_ES2 && !SDL_VIDEO_OPENGL
+