summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rust-1.30-gdb-llvm.patch
diff options
context:
space:
mode:
authorIvan Petkov <ivanppetkov@gmail.com>2019-02-27 19:53:21 -0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-05 13:43:09 +0100
commit1a3db0b22fdb4f545fb6fd8ecea478d93ec0ae5a (patch)
treea0034eeddaa83bf7144fdae5b986f9f79be7b639 /gnu/packages/patches/rust-1.30-gdb-llvm.patch
parentac5aad535cd48787c7355d4c22e7f0257b7940cc (diff)
downloadpatches-1a3db0b22fdb4f545fb6fd8ecea478d93ec0ae5a.tar
patches-1a3db0b22fdb4f545fb6fd8ecea478d93ec0ae5a.tar.gz
gnu: rust: Update to 1.31.1.
* gnu/patches/rust-1.30-gdb-llvm.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/rust.scm (rust): Rename to... (rust-1.29): ...this. (rust-1.30): New variable. (rust): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/patches/rust-1.30-gdb-llvm.patch')
-rw-r--r--gnu/packages/patches/rust-1.30-gdb-llvm.patch89
1 files changed, 89 insertions, 0 deletions
diff --git a/gnu/packages/patches/rust-1.30-gdb-llvm.patch b/gnu/packages/patches/rust-1.30-gdb-llvm.patch
new file mode 100644
index 0000000000..e8f0acc8b4
--- /dev/null
+++ b/gnu/packages/patches/rust-1.30-gdb-llvm.patch
@@ -0,0 +1,89 @@
+Tweak some gdb tests which were broken during LLVM upgrades.
+This has been subsequently fixed upstream in later rustc versions,
+but still needed to bootstrap some earlier versions of the compiler.
+
+diff -r -u rustc-1.30.1-src-orig/src/test/debuginfo/borrowed-c-style-enum.rs rustc-1.30.1-src/src/test/debuginfo/borrowed-c-style-enum.rs
+--- rustc-1.30.1-src-orig/src/test/debuginfo/borrowed-c-style-enum.rs 2019-02-04 12:49:34.055483896 -0800
++++ rustc-1.30.1-src/src/test/debuginfo/borrowed-c-style-enum.rs 2019-02-04 13:01:10.915950356 -0800
+@@ -18,15 +18,15 @@
+
+ // gdb-command:print *the_a_ref
+ // gdbg-check:$1 = TheA
+-// gdbr-check:$1 = borrowed_c_style_enum::ABC::TheA
++// gdbr-check:$1 = borrowed_c_style_enum::TheA
+
+ // gdb-command:print *the_b_ref
+ // gdbg-check:$2 = TheB
+-// gdbr-check:$2 = borrowed_c_style_enum::ABC::TheB
++// gdbr-check:$2 = borrowed_c_style_enum::TheB
+
+ // gdb-command:print *the_c_ref
+ // gdbg-check:$3 = TheC
+-// gdbr-check:$3 = borrowed_c_style_enum::ABC::TheC
++// gdbr-check:$3 = borrowed_c_style_enum::TheC
+
+
+ // === LLDB TESTS ==================================================================================
+diff -r -u rustc-1.30.1-src-orig/src/test/debuginfo/c-style-enum-in-composite.rs rustc-1.30.1-src/src/test/debuginfo/c-style-enum-in-composite.rs
+--- rustc-1.30.1-src-orig/src/test/debuginfo/c-style-enum-in-composite.rs 2019-02-04 12:49:34.051483727 -0800
++++ rustc-1.30.1-src/src/test/debuginfo/c-style-enum-in-composite.rs 2019-02-04 13:02:00.981997525 -0800
+@@ -19,31 +19,31 @@
+
+ // gdb-command:print tuple_interior_padding
+ // gdbg-check:$1 = {__0 = 0, __1 = OneHundred}
+-// gdbr-check:$1 = (0, c_style_enum_in_composite::AnEnum::OneHundred)
++// gdbr-check:$1 = (0, c_style_enum_in_composite::OneHundred)
+
+ // gdb-command:print tuple_padding_at_end
+ // gdbg-check:$2 = {__0 = {__0 = 1, __1 = OneThousand}, __1 = 2}
+-// gdbr-check:$2 = ((1, c_style_enum_in_composite::AnEnum::OneThousand), 2)
++// gdbr-check:$2 = ((1, c_style_enum_in_composite::OneThousand), 2)
+
+ // gdb-command:print tuple_different_enums
+ // gdbg-check:$3 = {__0 = OneThousand, __1 = MountainView, __2 = OneMillion, __3 = Vienna}
+-// gdbr-check:$3 = (c_style_enum_in_composite::AnEnum::OneThousand, c_style_enum_in_composite::AnotherEnum::MountainView, c_style_enum_in_composite::AnEnum::OneMillion, c_style_enum_in_composite::AnotherEnum::Vienna)
++// gdbr-check:$3 = (c_style_enum_in_composite::OneThousand, c_style_enum_in_composite::MountainView, c_style_enum_in_composite::OneMillion, c_style_enum_in_composite::Vienna)
+
+ // gdb-command:print padded_struct
+ // gdbg-check:$4 = {a = 3, b = OneMillion, c = 4, d = Toronto, e = 5}
+-// gdbr-check:$4 = c_style_enum_in_composite::PaddedStruct {a: 3, b: c_style_enum_in_composite::AnEnum::OneMillion, c: 4, d: c_style_enum_in_composite::AnotherEnum::Toronto, e: 5}
++// gdbr-check:$4 = c_style_enum_in_composite::PaddedStruct {a: 3, b: c_style_enum_in_composite::OneMillion, c: 4, d: c_style_enum_in_composite::Toronto, e: 5}
+
+ // gdb-command:print packed_struct
+ // gdbg-check:$5 = {a = 6, b = OneHundred, c = 7, d = Vienna, e = 8}
+-// gdbr-check:$5 = c_style_enum_in_composite::PackedStruct {a: 6, b: c_style_enum_in_composite::AnEnum::OneHundred, c: 7, d: c_style_enum_in_composite::AnotherEnum::Vienna, e: 8}
++// gdbr-check:$5 = c_style_enum_in_composite::PackedStruct {a: 6, b: c_style_enum_in_composite::OneHundred, c: 7, d: c_style_enum_in_composite::Vienna, e: 8}
+
+ // gdb-command:print non_padded_struct
+ // gdbg-check:$6 = {a = OneMillion, b = MountainView, c = OneThousand, d = Toronto}
+-// gdbr-check:$6 = c_style_enum_in_composite::NonPaddedStruct {a: c_style_enum_in_composite::AnEnum::OneMillion, b: c_style_enum_in_composite::AnotherEnum::MountainView, c: c_style_enum_in_composite::AnEnum::OneThousand, d: c_style_enum_in_composite::AnotherEnum::Toronto}
++// gdbr-check:$6 = c_style_enum_in_composite::NonPaddedStruct {a: c_style_enum_in_composite::OneMillion, b: c_style_enum_in_composite::MountainView, c: c_style_enum_in_composite::OneThousand, d: c_style_enum_in_composite::Toronto}
+
+ // gdb-command:print struct_with_drop
+ // gdbg-check:$7 = {__0 = {a = OneHundred, b = Vienna}, __1 = 9}
+-// gdbr-check:$7 = (c_style_enum_in_composite::StructWithDrop {a: c_style_enum_in_composite::AnEnum::OneHundred, b: c_style_enum_in_composite::AnotherEnum::Vienna}, 9)
++// gdbr-check:$7 = (c_style_enum_in_composite::StructWithDrop {a: c_style_enum_in_composite::OneHundred, b: c_style_enum_in_composite::Vienna}, 9)
+
+ // === LLDB TESTS ==================================================================================
+
+diff -r -u rustc-1.30.1-src-orig/src/test/debuginfo/gdb-pretty-struct-and-enums-pre-gdb-7-7.rs rustc-1.30.1-src/src/test/debuginfo/gdb-pretty-struct-and-enums-pre-gdb-7-7.rs
+--- rustc-1.30.1-src-orig/src/test/debuginfo/gdb-pretty-struct-and-enums-pre-gdb-7-7.rs 2019-02-04 12:49:34.043483393 -0800
++++ rustc-1.30.1-src/src/test/debuginfo/gdb-pretty-struct-and-enums-pre-gdb-7-7.rs 2019-02-04 13:02:17.954691634 -0800
+@@ -27,15 +27,15 @@
+
+ // gdb-command: print c_style_enum1
+ // gdbg-check:$3 = CStyleEnumVar1
+-// gdbr-check:$3 = gdb_pretty_struct_and_enums_pre_gdb_7_7::CStyleEnum::CStyleEnumVar1
++// gdbr-check:$3 = gdb_pretty_struct_and_enums_pre_gdb_7_7::CStyleEnumVar1
+
+ // gdb-command: print c_style_enum2
+ // gdbg-check:$4 = CStyleEnumVar2
+-// gdbr-check:$4 = gdb_pretty_struct_and_enums_pre_gdb_7_7::CStyleEnum::CStyleEnumVar2
++// gdbr-check:$4 = gdb_pretty_struct_and_enums_pre_gdb_7_7::CStyleEnumVar2
+
+ // gdb-command: print c_style_enum3
+ // gdbg-check:$5 = CStyleEnumVar3
+-// gdbr-check:$5 = gdb_pretty_struct_and_enums_pre_gdb_7_7::CStyleEnum::CStyleEnumVar3
++// gdbr-check:$5 = gdb_pretty_struct_and_enums_pre_gdb_7_7::CStyleEnumVar3
+
+ #![allow(dead_code, unused_variables)]