summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-jedi-sort-project-test.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-17 00:51:48 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-17 00:51:48 +0200
commitbff70d93d22b049c0c4ea3bd234d39f05f794b28 (patch)
treea49658584baab9c46846a4bbf0d4ef6d81165c74 /gnu/packages/patches/python-jedi-sort-project-test.patch
parent91fb989f105691a3c0b713c710bd9b27d4def4fc (diff)
downloadpatches-bff70d93d22b049c0c4ea3bd234d39f05f794b28.tar
patches-bff70d93d22b049c0c4ea3bd234d39f05f794b28.tar.gz
gnu: python-jedi: Fix test failure on some file systems.base-for-series-3577
Reported by sirgazil on #guix. * gnu/packages/patches/python-jedi-sort-project-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python-xyz.scm (python-jedi)[source](patches): Add it. [arguments]: Run tests more verbosely while at it.
Diffstat (limited to 'gnu/packages/patches/python-jedi-sort-project-test.patch')
-rw-r--r--gnu/packages/patches/python-jedi-sort-project-test.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-jedi-sort-project-test.patch b/gnu/packages/patches/python-jedi-sort-project-test.patch
new file mode 100644
index 0000000000..b2d602dfe6
--- /dev/null
+++ b/gnu/packages/patches/python-jedi-sort-project-test.patch
@@ -0,0 +1,18 @@
+Sort the result of file system traversal to avoid test failure on different
+file systems.
+
+Taken from upstream:
+https://github.com/davidhalter/jedi/commit/7ff76bb7d0d94514e17cd1647f4ffaf533dd55f5
+
+diff --git a/test/test_api/test_project.py b/test/test_api/test_project.py
+--- a/test/test_api/test_project.py
++++ b/test/test_api/test_project.py
+@@ -135,7 +135,7 @@ def test_search(string, full_names, kwargs, skip_pre_python36):
+ defs = project.complete_search(string, **kwargs)
+ else:
+ defs = project.search(string, **kwargs)
+- assert [('stub:' if d.is_stub() else '') + d.full_name for d in defs] == full_names
++ assert sorted([('stub:' if d.is_stub() else '') + d.full_name for d in defs]) == full_names
+
+
+ @pytest.mark.parametrize(