summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/perl-module-pluggable-search.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-01-20 17:12:53 -0600
committerEric Bavier <bavier@member.fsf.org>2016-01-20 17:45:31 -0600
commit97b07aaa419bfa069bb217fca2f158f6ea0804a1 (patch)
tree6728209273d2f4186edec642bf8830dbb79c4afc /gnu/packages/patches/perl-module-pluggable-search.patch
parent7b158c4ee2d4b5cf6a2cd9bf0246465c3c8a06ca (diff)
downloadpatches-97b07aaa419bfa069bb217fca2f158f6ea0804a1.tar
patches-97b07aaa419bfa069bb217fca2f158f6ea0804a1.tar.gz
gnu: Add perl-module-pluggable.
This Perl module was moved out of Perl core in v5.19.0. * gnu/packages/perl.scm (perl-module-pluggable): New variable. * gnu/packages/patches/perl-module-pluggable-search.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/perl-module-pluggable-search.patch')
-rwxr-xr-xgnu/packages/patches/perl-module-pluggable-search.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/perl-module-pluggable-search.patch b/gnu/packages/patches/perl-module-pluggable-search.patch
new file mode 100755
index 0000000000..ec51abc35d
--- /dev/null
+++ b/gnu/packages/patches/perl-module-pluggable-search.patch
@@ -0,0 +1,25 @@
+Fix Perl module Module::Pluggable such that it can find plugins that live in
+symlinked directories.
+
+Patch borrowed/adapted from Nixpkgs.
+
+--- Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500
++++ Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500
+@@ -164,7 +164,7 @@
+ my $sp = catdir($dir, (split /::/, $searchpath));
+
+ # if it doesn't exist or it's not a dir then skip it
+- next unless ( -e $sp && -d _ ); # Use the cached stat the second time
++ next unless ( -e $sp );
+
+ my @files = $self->find_files($sp);
+
+@@ -279,7 +279,7 @@
+ (my $path = $File::Find::name) =~ s#^\\./##;
+ push @files, $path;
+ }
+- }, $search_path );
++ }, "$search_path/." );
+ }
+ #chdir $cwd;
+ return @files; \ No newline at end of file