aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mupdf-build-with-latest-openjpeg.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-21 01:53:48 -0500
committerLeo Famulari <leo@famulari.name>2017-12-21 02:00:59 -0500
commitdab2542f845bf1b6b7761f1be6fc55b9259238fe (patch)
treef4980a041d31746dd9609d7ee8a0659858bb6403 /gnu/packages/patches/mupdf-build-with-latest-openjpeg.patch
parent91213c384b62bc422896d39005efa922e4fa75f2 (diff)
downloadpatches-dab2542f845bf1b6b7761f1be6fc55b9259238fe.tar
patches-dab2542f845bf1b6b7761f1be6fc55b9259238fe.tar.gz
gnu: mupdf: Update to 1.12.0 [fixes CVE-2017-15369].
* gnu/packages/pdf.scm (mupdf): Update to 1.12.0. [source]: Remove obsolete patches. [inputs]: Add freeglut. * gnu/packages/patches/mupdf-CVE-2017-14685.patch, gnu/packages/patches/mupdf-CVE-2017-14686.patch, gnu/packages/patches/mupdf-CVE-2017-14687.patch, gnu/packages/patches/mupdf-CVE-2017-15587.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/patches/mupdf-build-with-openjpeg-2.1.patch: Update and rename to... * gnu/packages/patches/mupdf-build-with-latest-openjpeg.patch: ... new file.
Diffstat (limited to 'gnu/packages/patches/mupdf-build-with-latest-openjpeg.patch')
-rw-r--r--gnu/packages/patches/mupdf-build-with-latest-openjpeg.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/mupdf-build-with-latest-openjpeg.patch b/gnu/packages/patches/mupdf-build-with-latest-openjpeg.patch
new file mode 100644
index 0000000000..d5c9c60242
--- /dev/null
+++ b/gnu/packages/patches/mupdf-build-with-latest-openjpeg.patch
@@ -0,0 +1,27 @@
+Make it possible to build MuPDF with OpenJPEG 2.3, which is the latest
+release series and contains many important bug fixes.
+
+Patch adapted from Debian:
+
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=745246
+
+And related to this upstream commit:
+
+http://git.ghostscript.com/?p=mupdf.git;a=commit;h=f88bfe2e62dbadb96d4f52d7aa025f0a516078da
+
+diff --git a/source/fitz/load-jpx.c b/source/fitz/load-jpx.c
+index 65699ba..ea84778 100644
+--- a/source/fitz/load-jpx.c
++++ b/source/fitz/load-jpx.c
+@@ -445,11 +445,6 @@ fz_load_jpx_info(fz_context *ctx, const unsigned char *data, size_t size, int *w
+
+ #else /* HAVE_LURATECH */
+
+-#define OPJ_STATIC
+-#define OPJ_HAVE_INTTYPES_H
+-#if !defined(_MSC_VER) || _MSC_VER >= 1600
+-#define OPJ_HAVE_STDINT_H
+-#endif
+ #define USE_JPIP
+
+ #include <openjpeg.h>