summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2020-03-24 17:19:33 -0400
committerCarl Dong <contact@carldong.me>2020-04-04 16:23:07 -0400
commit4719b715726303d680cd6f65caad96bfa194cda6 (patch)
tree49d31181e0f3e195000798ea46062dfabd43a388 /gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
parent19b10c91e82a64ef989adf8dcdff0a291ca0675b (diff)
downloadpatches-4719b715726303d680cd6f65caad96bfa194cda6.tar
patches-4719b715726303d680cd6f65caad96bfa194cda6.tar.gz
gnu: mingw: Add mingw-w64 reproducibility patches.base-for-series-3439
These patches were originally found at the debian mingw-w64 team's mingw-w64 repo, and should improve the reproducibility of our mingw-w64 toolchain. * gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch: New file. * gnu/packages/patches/mingw-w64-reproducible-gendef.patch: New file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/mingw.scm (make-mingw-w64): Apply patches.
Diffstat (limited to 'gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch')
-rw-r--r--gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch b/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
new file mode 100644
index 0000000000..432cafc162
--- /dev/null
+++ b/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
@@ -0,0 +1,26 @@
+This following patch was originally found at the debian mingw-w64 team's
+mingw-w64 repo located here:
+https://salsa.debian.org/mingw-w64-team/mingw-w64.git
+
+Invoke the following in the aforementioned repo to see the original patch:
+
+ $ git show 4974e2c:debian/patches/dlltool-temp-prefix.patch
+
+Description: Specify dlltool's temp prefix
+Author: Stephen Kitt <steve@sk2.org>
+
+By default dlltool uses its pid for the object files it generates.
+Enforcing its temp prefix allows the files it generates to be
+reproducible.
+
+--- a/mingw-w64-crt/Makefile.am
++++ b/mingw-w64-crt/Makefile.am
+@@ -36,7 +36,7 @@
+ DTDEF32=$(GENLIB) $(DLLTOOLFLAGS32) $(AM_DLLTOOLFLAGS)
+ DTDEF64=$(GENLIB) $(DLLTOOLFLAGS64) $(AM_DLLTOOLFLAGS)
+ else
+- AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@
++ AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@ --temp-prefix $$(basename $@ .a)
+ DLLTOOLFLAGSARM32=-m arm
+ DLLTOOLFLAGSARM64=-m arm64
+ DLLTOOLFLAGS32=--as-flags=--32 -m i386