summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2019-12-05 01:47:47 +0530
committerArun Isaac <arunisaac@systemreboot.net>2019-12-26 18:54:42 +0530
commitf9d328833fc1f5d0fb76b61b12d1a3cb013932e6 (patch)
tree46df95788894a5bf0af3e49b862b0f8caa810114 /gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch
parent3500d7addc2f9b2067ffd239383eb0e546be4f43 (diff)
downloadpatches-f9d328833fc1f5d0fb76b61b12d1a3cb013932e6.tar
patches-f9d328833fc1f5d0fb76b61b12d1a3cb013932e6.tar.gz
gnu: libgeotiff: Update to 1.5.1.
* gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/geo.scm (libgeotiff): Update to 1.5.1. [inputs]: Replace proj.4 with proj. [sources]: Add libgeotiff-adapt-test-script-for-proj-6.2.patch to patches.
Diffstat (limited to 'gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch')
-rw-r--r--gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch b/gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch
new file mode 100644
index 0000000000..746610c095
--- /dev/null
+++ b/gnu/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch
@@ -0,0 +1,63 @@
+From 678ffd97db2d63cf6856428bea65a93e069f812f Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Wed, 4 Sep 2019 16:11:37 +0200
+Subject: [PATCH 1/2] Adapt test script for PROJ 6.2 EPSG database (fixes #22)
+
+---
+ libgeotiff/test/testlistgeo | 8 +++++++-
+ libgeotiff/test/testlistgeo_out.dist | 4 ++--
+ 2 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/libgeotiff/test/testlistgeo b/libgeotiff/test/testlistgeo
+index 7fb4a2f..571f5d0 100755
+--- a/test/testlistgeo
++++ b/test/testlistgeo
+@@ -210,10 +210,15 @@ echo "Testing listgeo equidistant_cylindrical.tif" >> ${OUT}
+ $EXE ${DATA_DIR}/equidistant_cylindrical.tif >>${OUT}
+ echo "" >>${OUT}
+
++# Normalize for results depending on the exact version of PROJ / EPSG database
++sed "s/ETRS89-extended/ETRS89/g" < ${OUT} > ${OUT}.tmp
++mv ${OUT}.tmp ${OUT}
++
++sed "s/ETRS89-extended/ETRS89/g" < ${TEST_CLI_DIR}/testlistgeo_out.dist > testlistgeo_out.dist.tmp
+
+ # do 'diff' with distribution results
+ echo "diff ${OUT} with testlistgeo_out.dist"
+-diff -u ${OUT} ${TEST_CLI_DIR}/testlistgeo_out.dist
++diff -u ${OUT} testlistgeo_out.dist.tmp
+ if [ $? -ne 0 ] ; then
+ echo ""
+ echo "PROBLEMS HAVE OCCURRED"
+@@ -224,6 +229,7 @@ else
+ echo "TEST OK"
+ echo "test file ${OUT} removed"
+ echo
++ rm testlistgeo_out.dist.tmp
+ /bin/rm -f ${OUT}
+ exit 0
+ fi
+diff --git a/libgeotiff/test/testlistgeo_out.dist b/libgeotiff/test/testlistgeo_out.dist
+index 68a948c..c157f00 100644
+--- a/test/testlistgeo_out.dist
++++ b/test/testlistgeo_out.dist
+@@ -1738,11 +1738,11 @@ Geotiff_Information:
+ Keyed_Information:
+ GTModelTypeGeoKey (Short,1): ModelTypeProjected
+ GTRasterTypeGeoKey (Short,1): RasterPixelIsArea
+- ProjectedCSTypeGeoKey (Short,1): Code-3035 (ETRS89 / LAEA Europe)
++ ProjectedCSTypeGeoKey (Short,1): Code-3035 (ETRS89-extended / LAEA Europe)
+ End_Of_Keys.
+ End_Of_Geotiff.
+
+-PCS = 3035 (ETRS89 / LAEA Europe)
++PCS = 3035 (ETRS89-extended / LAEA Europe)
+ Projection = 19986 (Europe Equal Area 2001)
+ Projection Method: CT_LambertAzimEqualArea
+ ProjCenterLatGeoKey: 52.000000 ( 52d 0' 0.00"N)
+
+From 15af10648c4cb7b4c55cbe08caaf9884c1d156d9 Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Wed, 4 Sep 2019 19:13:11 +0200
+Subject: [PATCH 2/2] appveyor.yml: build vcpkg from source to fix issue with
+ VS2015