summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glibc-vectorized-strcspn-guards.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-06-25 20:58:17 -0400
committerMark H Weaver <mhw@netris.org>2017-06-25 21:56:22 -0400
commitffc015bea26f24d862e7e877d907fbe1ab9a9967 (patch)
tree0386ba824424b7c64b9adf5845e1ba93e9fcf626 /gnu/packages/patches/glibc-vectorized-strcspn-guards.patch
parentafc9d8ec2b724b67f85b05011725bb636f209a1a (diff)
downloadpatches-ffc015bea26f24d862e7e877d907fbe1ab9a9967.tar
patches-ffc015bea26f24d862e7e877d907fbe1ab9a9967.tar.gz
gnu: glibc: Fix replacement on i686.
This is followup to 665d6a59161769e10b52ffcbcd5cd2db22f32681. Fixes <https://bugs.gnu.org/27489>. * gnu/packages/base.scm (glibc-2.25-patched, glibc-2.24, glibc-2.23) (glibc-2.22): Add glibc-vectorized-strcspn-guards.patch to patches. Move a comment where it belongs. * gnu/packages/patches/glibc-CVE-2017-1000366-pt2.patch: Swap with ... * gnu/packages/patches/glibc-CVE-2017-1000366-pt3.patch: ... this. * gnu/packages/patches/glibc-vectorized-strcspn-guards.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Fix formatting.
Diffstat (limited to 'gnu/packages/patches/glibc-vectorized-strcspn-guards.patch')
-rw-r--r--gnu/packages/patches/glibc-vectorized-strcspn-guards.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/glibc-vectorized-strcspn-guards.patch b/gnu/packages/patches/glibc-vectorized-strcspn-guards.patch
new file mode 100644
index 0000000000..3d6c7749d4
--- /dev/null
+++ b/gnu/packages/patches/glibc-vectorized-strcspn-guards.patch
@@ -0,0 +1,23 @@
+Copied from Debian.
+
+2017-06-14 Florian Weimer <fweimer@redhat.com>
+
+ * sysdeps/i386/i686/multiarch/strcspn-c.c: Add IS_IN (libc) guard.
+ * sysdeps/i386/i686/multiarch/varshift.c: Likewise.
+
+--- a/sysdeps/i386/i686/multiarch/strcspn-c.c
++++ b/sysdeps/i386/i686/multiarch/strcspn-c.c
+@@ -1,2 +1,4 @@
+-#define __strcspn_sse2 __strcspn_ia32
+-#include <sysdeps/x86_64/multiarch/strcspn-c.c>
++#if IS_IN (libc)
++# define __strcspn_sse2 __strcspn_ia32
++# include <sysdeps/x86_64/multiarch/strcspn-c.c>
++#endif
+--- a/sysdeps/i386/i686/multiarch/varshift.c
++++ b/sysdeps/i386/i686/multiarch/varshift.c
+@@ -1 +1,3 @@
+-#include <sysdeps/x86_64/multiarch/varshift.c>
++#if IS_IN (libc)
++# include <sysdeps/x86_64/multiarch/varshift.c>
++#endif