summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/fuse-overlapping-headers.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-04-25 21:18:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-04-26 08:45:24 +0300
commitcd48a549025375bc03ddc0fd9a95ce3bcbf7f284 (patch)
treeb7b3a19dbe39b0ec7524f0c1bfc1cd58837705b0 /gnu/packages/patches/fuse-overlapping-headers.patch
parentd26ae96c3da6d968cd38348197f3581e456e56cc (diff)
downloadpatches-cd48a549025375bc03ddc0fd9a95ce3bcbf7f284.tar
patches-cd48a549025375bc03ddc0fd9a95ce3bcbf7f284.tar.gz
gnu: fuse: Patch conflicting headers with the kernel.
* gnu/packages/linux.scm (fuse)[source]: Add patch. * gnu/packages/patches/fuse-overlapping-headers.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/fuse-overlapping-headers.patch')
-rw-r--r--gnu/packages/patches/fuse-overlapping-headers.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/fuse-overlapping-headers.patch b/gnu/packages/patches/fuse-overlapping-headers.patch
new file mode 100644
index 0000000000..54f9c0e709
--- /dev/null
+++ b/gnu/packages/patches/fuse-overlapping-headers.patch
@@ -0,0 +1,28 @@
+This patch is from Debian, named '0006-arm64.patch'
+
+Author: Riku Voipio <riku.voipio@linaro.org>
+Description: fuse_kernel.h: clean includes
+ Use <linux/types.h> for linux and define types used for other operating systems
+ using <stdint.h> types (Closes: #752081).
+
+diff -Naurp fuse.orig/include/fuse_kernel.h fuse/include/fuse_kernel.h
+--- fuse.orig/include/fuse_kernel.h
++++ fuse/include/fuse_kernel.h
+@@ -88,12 +88,16 @@
+ #ifndef _LINUX_FUSE_H
+ #define _LINUX_FUSE_H
+
+-#include <sys/types.h>
++#ifdef __linux__
++#include <linux/types.h>
++#else
++#include <stdint.h>
+ #define __u64 uint64_t
+ #define __s64 int64_t
+ #define __u32 uint32_t
+ #define __s32 int32_t
+ #define __u16 uint16_t
++#endif
+
+ /*
+ * Version negotiation: