summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-02 19:24:33 -0500
committerLeo Famulari <leo@famulari.name>2017-01-03 12:35:45 -0500
commitf339f2773da39cf8ea312c3ba06a4660bf557e84 (patch)
tree2247927394a8e328ebe07575fe50bacd322d7078 /gnu/packages/password-utils.scm
parent7637de2313bb5caee2dcfcc917a3e77e0ce318f9 (diff)
downloadpatches-f339f2773da39cf8ea312c3ba06a4660bf557e84.tar
patches-f339f2773da39cf8ea312c3ba06a4660bf557e84.tar.gz
gnu: assword: Update to 0.10.
* gnu/packages/password-utils.scm (assword): Update to 0.10. [arguments]: Use Python 3 instead of Python 2. [inputs]: Use Python 3 variants of inputs. Replace python2-pygpgme with python-gpg. Remove python2-pygtk. Add python-pygobject. [native-inputs]: Replace help2man with txt2man. [arguments]: Remove PYTHONPATH from 'Makefile' in the 'manpage' phase.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index c0d8d39a63..f8111b2abf 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,8 +34,8 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
- #:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
@@ -216,7 +217,7 @@ random passwords that pass the checks.")
(define-public assword
(package
(name "assword")
- (version "0.8")
+ (version "0.10")
(source (origin
(method url-fetch)
(uri (list
@@ -225,10 +226,9 @@ random passwords that pass the checks.")
"assword_" version ".orig.tar.gz")))
(sha256
(base32
- "0dl4wizbi0r21wxzykm8s445xbvqim5nabi799dmpkdnnh8i546i"))))
+ "0l6170y6my1gprqkazvzabgjkrkr9v2q7z48vjflna4r323yqira"))))
(arguments
- `(#:python ,python-2
- ;; irritatingly, tests do run but not there are two problems:
+ `(;; irritatingly, tests do run but not there are two problems:
;; - "import gtk" fails for unknown reasons here despite it the
;; program working (indeed, I've found I have to do a logout and log
;; back in in after an install order for some mumbo jumbo environment
@@ -242,17 +242,21 @@ random passwords that pass the checks.")
(add-after 'install 'manpage
(lambda* (#:key outputs #:allow-other-keys)
(and
+ ;; Without this substitution, it fails with
+ ;; ImportError: No module named 'gpg'
+ (substitute* "Makefile"
+ (("PYTHONPATH=.") ""))
(zero? (system* "make" "assword.1"))
(install-file
"assword.1"
(string-append (assoc-ref outputs "out") "/share/man/man1"))))))))
(build-system python-build-system)
(native-inputs
- `(("help2man" ,help2man)))
+ `(("txt2man" ,txt2man)))
(inputs
- `(("python2-xdo" ,python2-xdo)
- ("python2-pygpgme" ,python2-pygpgme)
- ("python2-pygtk" ,python2-pygtk)))
+ `(("python-xdo" ,python-xdo)
+ ("python-gpg" ,python-gpg)
+ ("python-pygobject" ,python-pygobject)))
(propagated-inputs
`(("xclip" ,xclip)))
(home-page "https://finestructure.net/assword/")