summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-13 11:41:51 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-13 18:16:35 +0100
commit2e69dd8c1d07dc88d9439ceb012b31c28b0dd1f5 (patch)
treeec3388b48d52f8aa3b9c05e84bf5ea7bffeb2f32 /gnu/packages/package-management.scm
parent765f0ac8f9f67f775a667a4276faf85ddde6d7ea (diff)
downloadpatches-2e69dd8c1d07dc88d9439ceb012b31c28b0dd1f5.tar
patches-2e69dd8c1d07dc88d9439ceb012b31c28b0dd1f5.tar.gz
gnu: guix: Update snapshot.
* gnu/packages/package-management.scm (guix-devel): Update snapshot. Remove now-unneeded sub-module stuff in the 'bootstrap' phase.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm27
1 files changed, 4 insertions, 23 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 408734d6fa..1531e867e9 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -118,42 +118,23 @@ the Nix package manager.")
(define guix-devel
;; Development version of Guix.
- (let ((commit "3b09332"))
+ (let ((commit "4655005"))
(package (inherit guix-0.8)
(version (string-append "0.8." commit))
(source (origin
(method git-fetch)
(uri (git-reference
(url "git://git.sv.gnu.org/guix.git")
- (commit commit)
- (recursive? #t)))
+ (commit commit)))
(sha256
(base32
- "1szlyhpy688ca96kfyjb6cdy5zhxvqmdig4m7ql7rjqfmz0gvka1"))))
+ "04dmmnr88mwpsl0mmv03hpllyinn9cs4mmly8k0jm2acwnsni3ii"))))
(arguments
(substitute-keyword-arguments (package-arguments guix-0.8)
((#:phases phases)
`(alist-cons-before
'configure 'bootstrap
(lambda _
- ;; Comment out `git' invocations, since 'git-fetch' provides us
- ;; with a checkout that includes sub-modules.
- (substitute* "bootstrap"
- (("git ")
- "true git "))
-
- ;; Keep a list of the files already available under nix/...
- (call-with-output-file "ls-R"
- (lambda (port)
- (for-each (lambda (file)
- (format port "~a~%" file))
- (find-files "nix" ""))))
-
- ;; ... and use that as a substitute to 'git ls-tree'.
- (substitute* "nix/sync-with-upstream"
- (("git ls-tree HEAD -- [[:graph:]]+")
- "cat ls-R"))
-
;; Make sure 'msgmerge' can modify the PO files.
(for-each (lambda (po)
(chmod po #o666))