summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
commit57df83e07d4b5e78d9a54c1a88d05b4a9ed65714 (patch)
tree76684e63965e9ad6e37d9d45bc3159e6c9782cd0 /gnu/packages/package-management.scm
parent43d9ed7792808638eabb43aa6133f1d6186c520b (diff)
parent136b7d81f0eb713783e9ea7cf7f260a2b6252dfd (diff)
downloadpatches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar
patches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 697a04e098..a356a6dab7 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
+;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -109,9 +110,9 @@
;; Latest version of Guix, which may or may not correspond to a release.
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
- (let ((version "0.16.0")
- (commit "0c329bf4b0c00abdc9a7d9c818d36d4d60b3005d")
- (revision 14))
+ (let ((version "1.0.1")
+ (commit "820429517f9cc8333704a839b4346ac4b02468c4")
+ (revision 1))
(package
(name "guix")
@@ -127,7 +128,7 @@
(commit commit)))
(sha256
(base32
- "1403vrazx46w9hcvqjyxa4ipwvqv0432f6rsn4981w1n3p1j4mf6"))
+ "1vfp7ps1k1cwn8p0gsgarlxcy982hzyvb7zqnj66jqd258a1qfgh"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -493,7 +494,7 @@ symlinks to the files in a common directory such as /usr/local.")
(define-public rpm
(package
(name "rpm")
- (version "4.14.2")
+ (version "4.14.2.1")
(source (origin
(method url-fetch)
(uri (string-append "http://ftp.rpm.org/releases/rpm-"
@@ -501,7 +502,7 @@ symlinks to the files in a common directory such as /usr/local.")
version ".tar.bz2"))
(sha256
(base32
- "0armd7dqr8bl0isx8l4xlylm7dikasmxhhcbz336fkp2x30w5jw0"))))
+ "1nmck2fq9h85fgs3zhh6w1avlw5y16cbz5khd459ry3jfd5w4f8i"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-external-db" ;use the system's bdb
@@ -518,7 +519,7 @@ symlinks to the files in a common directory such as /usr/local.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("python" ,python-2)
+ `(("python" ,python)
("xz" ,xz)
("bdb" ,bdb)
("popt" ,popt)
@@ -530,7 +531,7 @@ symlinks to the files in a common directory such as /usr/local.")
("bzip2" ,bzip2)
("zlib" ,zlib)
("cpio" ,cpio)))
- (home-page "http://rpm.org/")
+ (home-page "https://rpm.org/")
(synopsis "The RPM Package Manager")
(description
"The RPM Package Manager (RPM) is a command-line driven package