summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-20 16:13:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-20 16:18:58 +0300
commitf8f83e9d219a8cf1d99749b81b06a4710ad5f09c (patch)
treeff614ff6f367204f7db409c2bf5614fa789200e5 /gnu/packages/openstack.scm
parent4b42bd941bad43e251e107674dcc2b77cdfa3071 (diff)
downloadpatches-f8f83e9d219a8cf1d99749b81b06a4710ad5f09c.tar
patches-f8f83e9d219a8cf1d99749b81b06a4710ad5f09c.tar.gz
gnu: python-mox3: Update to 0.14.0.
* gnu/packages/openstack.scm (python-mox3): Update to 0.14.0. [inputs]: Move python-fixtures, python-pbr, python-setuptools, python-six, python-testtools ... [native-inputs]: ... to here.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 7ae5421bba..780fb7f252 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -137,16 +137,16 @@ guidelines}.")
(define-public python-mox3
(package
(name "python-mox3")
- (version "0.13.0")
+ (version "0.14.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "mox3" version))
(sha256
(base32
- "0hj57374r239cj1zbzpxw7mj0yfblz55jdfrc2p1h8j7xng0319j"))))
+ "0njmh40i1lg5mzn9hc2ax83adj6dli455j6xifilrw27c4wlkjzx"))))
(build-system python-build-system)
- (inputs
+ (native-inputs
`(("python-fixtures" ,python-fixtures)
("python-pbr" ,python-pbr)
("python-setuptools" ,python-setuptools)
@@ -156,11 +156,14 @@ guidelines}.")
(synopsis "Mock object framework for Python")
(description
"Mox3 is an unofficial port of the Google mox framework
-(http://code.google.com/p/pymox/) to Python 3. It was meant to be as compatible
-with mox as possible, but small enhancements have been made. The library was
+(http://code.google.com/p/pymox/) to Python 3. It was meant to be as compatible
+with mox as possible, but small enhancements have been made. The library was
tested on Python version 3.2, 2.7 and 2.6.")
(license asl2.0)))
+(define-public python2-mox3
+ (package-with-python2 python-mox3))
+
(define-public python-os-client-config
(package
(name "python-os-client-config")
@@ -197,9 +200,6 @@ tested on Python version 3.2, 2.7 and 2.6.")
(define-public python2-os-client-config
(package-with-python2 python-os-client-config))
-(define-public python2-mox3
- (package-with-python2 python-mox3))
-
(define-public python-os-testr
(package
(name "python-os-testr")