summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-10 11:37:52 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:27 +0100
commite116d100fd8f87c65bab91a5a599804d5fb64708 (patch)
treed4940b821f3667fe0d27013df29b7f42e8c96db1 /gnu/packages/openstack.scm
parent48160559a1a443f8d3024376ab79a925b25ebc42 (diff)
downloadpatches-e116d100fd8f87c65bab91a5a599804d5fb64708.tar
patches-e116d100fd8f87c65bab91a5a599804d5fb64708.tar.gz
gnu: openstack: Correct inputs.
* gnu/packages/openstack.scm (python-os-testr) Propagate input python-subunit, change all other inputs to native-inputs. (python-mox3): Remove needless input python-six. (python-stevedore, python-requests-mock): Move python-pbr to native-inputs.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm19
1 files changed, 8 insertions, 11 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 55fd005f9b..e2672668d8 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -149,7 +149,6 @@ guidelines}.")
(native-inputs
`(("python-fixtures" ,python-fixtures)
("python-pbr" ,python-pbr)
- ("python-six" ,python-six)
("python-testtools" ,python-testtools)))
(home-page "http://www.openstack.org/")
(synopsis "Mock object framework for Python")
@@ -217,11 +216,11 @@ tested on Python version 3.2, 2.7 and 2.6.")
;; when building the package. Skip the tests for now.
`(#:tests? #f))
(propagated-inputs
+ `(("python-subunit" ,python-subunit)))
+ (native-inputs
`(("python-pbr" ,python-pbr)
- ("python-subunit" ,python-subunit)
- ("python-testtools" ,python-testtools)))
- (inputs
- `(("python-babel" ,python-babel)))
+ ("python-testtools" ,python-testtools)
+ ("python-babel" ,python-babel)))
(home-page "https://www.openstack.org/")
(synopsis "Testr wrapper to provide functionality for OpenStack projects")
(description
@@ -247,10 +246,9 @@ tested on Python version 3.2, 2.7 and 2.6.")
(propagated-inputs
`(("python-requests" ,python-requests)
("python-six" ,python-six)))
- (inputs
- `(("python-pbr" ,python-pbr)))
(native-inputs
- `(("python-discover" ,python-discover)
+ `(("python-pbr" ,python-pbr)
+ ("python-discover" ,python-discover)
("python-docutils" ,python-docutils)
("python-fixtures" ,python-fixtures)
("python-mock" ,python-mock)
@@ -281,10 +279,9 @@ portions of your testing code.")
(build-system python-build-system)
(propagated-inputs
`(("python-six" ,python-six)))
- (inputs
- `(("python-pbr" ,python-pbr)))
(native-inputs
- `(;; Tests
+ `(("python-pbr" ,python-pbr)
+ ;; Tests
("python-docutils" ,python-docutils)
("python-mock" ,python-mock)
("python-oslotest" ,python-oslotest)