summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-13 14:05:11 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:05 +0100
commit482d95918e2a9de05ee224d979c15759e54febf0 (patch)
tree578cba1bd70c924ad4027a9aa31716d7dd1e87c2 /gnu/packages/openstack.scm
parentdae73d9b9a4db932e8c7c1b7607981dc6cb401a5 (diff)
downloadpatches-482d95918e2a9de05ee224d979c15759e54febf0.tar
patches-482d95918e2a9de05ee224d979c15759e54febf0.tar.gz
gnu: Fix python inputs, part 5: some inputs become propagated-inputs
* gnu/packages/openstack.scm (python-os-client-config)[inputs] change to [native-inputs]. [propagated-inputs]: New element, move python-appdirs, python-pyyaml here. (python-git-review)[propagated-inputs]: New element, move python-requests here. * gnu/packages/python.scm (python-rpy2)[propagated-inputs]: New element, move python-six here. (python-xcffib)[inputs] move python-six to [propagated-inputs]. (python-flake8)[propagated-inputs]: New element, move python-pep8, python-pyflakes, python-mccabe here. (python-flake8-2.2.4)[propagated-inputs]: New element, move python-pep8, python-pyflakes, python-mccabe here. (python-pytest)[propagated-inputs]: New element, move python-py here. (python-tox)[propagated-inputs]: New element, move all inputs except of python-pytest here. (python-botocore)[propagated-inputs]: New element, move python-dateutil, python-docutils, python-jmespath here. (awscli)[propagated-inputs]: New element, move python-colorama, python-botocore, python-s3transfer, python-docutils, python-rsa here. (python-mako)[propagated-inputs]: New element, move python-markupsafe here. * gnu/packages/qemu.scm(python-libvirt)[propagated-inputs]: New element, move python-lxml here.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 327c4f984e..55fd005f9b 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -177,12 +177,13 @@ tested on Python version 3.2, 2.7 and 2.6.")
(build-system python-build-system)
(arguments
`(#:tests? #f)) ;; Circular dependency with python-oslotest
- (inputs
+ (propagated-inputs
`(("python-appdirs" ,python-appdirs)
+ ("python-pyyaml" ,python-pyyaml)))
+ (native-inputs
+ `(("python-pbr" ,python-pbr)
("python-fixtures" ,python-fixtures)
("python-mimeparse" ,python-mimeparse)
- ("python-pbr" ,python-pbr)
- ("python-pyyaml" ,python-pyyaml)
("python-testrepository" ,python-testrepository)
("python-testscenarios" ,python-testscenarios)
("python-testtools" ,python-testtools)))
@@ -790,9 +791,10 @@ permanence.")
(list git openssh))))))))))
(native-inputs
`(("python-pbr" ,python-pbr)))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
(inputs
- `(("python-requests" ,python-requests)
- ("git" ,git)
+ `(("git" ,git)
("openssh" ,openssh)))
(home-page "http://docs.openstack.org/infra/git-review/")
(synopsis "Command-line tool for Gerrit")