aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-30 17:06:00 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-30 17:06:00 +0200
commit0734a9a8131525d6da2e7bf802402dc0350eda98 (patch)
treef43bef210f6513b12c14ee9494bb47e4f80e99d0 /gnu/packages/openldap.scm
parente0fbbc889d724678e9e310432ad3a3fb8345cf9a (diff)
parent01155b1808b17f0a4f54388261ab0c6f5fee2f1b (diff)
downloadpatches-0734a9a8131525d6da2e7bf802402dc0350eda98.tar
patches-0734a9a8131525d6da2e7bf802402dc0350eda98.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index d2525a6310..a4a28ccf1b 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -55,7 +55,7 @@
("libtool" ,libtool "bin")
("zlib" ,zlib)))
(arguments
- `(#:parallel-tests? #f
+ `(#:tests? #f
#:phases
(alist-replace
'configure
@@ -63,19 +63,7 @@
(let ((configure (assoc-ref %standard-phases 'configure)))
(apply configure args)
(copy-file (which "libtool") "libtool")))
- (alist-replace
- 'check
- (lambda* (#:key #:allow-other-keys #:rest args)
- (let ((check (assoc-ref %standard-phases 'check)))
- (for-each (lambda (f)
- (substitute* (string-append "tests/scripts/" f)
- (("/bin/rm") "rm")))
- '("all" "its-all" "passwd-search" "sql-all" "test027-emptydn"))
- ;; disable especially finicky tests
- (delete-file "tests/scripts/test058-syncrepl-asymmetric")
- (delete-file "tests/scripts/test061-syncreplication-initiation")
- (apply check args)))
- %standard-phases))))
+ %standard-phases)))
(synopsis "openldap, an implementation of the Lightweight Directory Access Protocol")
(description
"OpenLDAP is a free implementation of the Lightweight Directory Access Protocol.")