summaryrefslogtreecommitdiff
path: root/gnu/packages/opencl.scm
diff options
context:
space:
mode:
authorIvan Gankevich <i.gankevich@spbu.ru>2019-10-30 19:05:09 +0300
committerMarius Bakke <mbakke@fastmail.com>2019-10-31 01:03:27 +0100
commitbbad38f4d8e6b6ecc15c476b973094cdf96cdeae (patch)
treea3020fea3a3ab40e165c029a02d95d9a29d408b0 /gnu/packages/opencl.scm
parentb8806e13dc230fa6abc0487860b6774dc0adce09 (diff)
downloadpatches-bbad38f4d8e6b6ecc15c476b973094cdf96cdeae.tar
patches-bbad38f4d8e6b6ecc15c476b973094cdf96cdeae.tar.gz
gnu: pocl: Update to 1.4.
* gnu/packages/opencl.scm (pocl): Update to 1.4. [inputs]: Change from LLVM to LLVM-8. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/opencl.scm')
-rw-r--r--gnu/packages/opencl.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index fc9c11caa5..81e5bab9db 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -296,7 +296,7 @@ back-end for the LLVM compiler framework.")
(define-public pocl
(package
(name "pocl")
- (version "1.2")
+ (version "1.4")
(source
(origin
(method git-fetch)
@@ -304,7 +304,7 @@ back-end for the LLVM compiler framework.")
(url "https://github.com/pocl/pocl.git")
(commit (string-append "v" version))))
(sha256
- (base32 "0fyiwd9nrqhl0jsac0bx17p9acpfzhyxp50mmp28mzn7psb9qidg"))
+ (base32 "1c4y69zks6hkq5fqh9waxgb8g4ka7y6h3vacmsm720kba0h57g8a"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs
@@ -313,7 +313,7 @@ back-end for the LLVM compiler framework.")
(inputs
`(("clang" ,clang)
("hwloc" ,hwloc-2.0 "lib")
- ("llvm" ,llvm)
+ ("llvm" ,llvm-8)
("ocl-icd" ,ocl-icd)))
(arguments
`(#:configure-flags