summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-09-04 23:06:51 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-09-04 23:08:49 +0200
commitce502774b4eba7aaa4c1d5eb07c913d6f06ff0dc (patch)
tree85766d766491a4df60c5e9d52f0abff4c6c3a0ad /gnu/packages/ocaml.scm
parente57dd20118d3210de0ce9e407f41bf3a0be1dee3 (diff)
downloadpatches-ce502774b4eba7aaa4c1d5eb07c913d6f06ff0dc.tar
patches-ce502774b4eba7aaa4c1d5eb07c913d6f06ff0dc.tar.gz
gnu: ocaml-easy-format: Update to 1.3.2.
* gnu/packages/ocaml.scm (ocaml-easy-format): Update to 1.3.2.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 67a5f01c7a..146fb63d5e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2753,19 +2753,28 @@ JSON.")
(define-public ocaml-easy-format
(package
(name "ocaml-easy-format")
- (version "1.3.1")
+ (version "1.3.2")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/mjambon/easy-format")
- (commit (string-append "v" version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "0jfncci15b8sf1y72yrxfjlsmhs9aavcd14vwz4d7kj8k9w9c4qk"))))
+ "1fc95q2ypck6m6rv3kiawwilh5ac93v2hcp823mj608d5kj79xkb"))))
(build-system dune-build-system)
(arguments
- `(#:jbuild? #t))
+ `(#:jbuild? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'make-writable
+ (lambda _
+ (for-each
+ (lambda (file)
+ (chmod file #o644))
+ (find-files "." "."))
+ #t)))))
(home-page "https://github.com/mjambon/easy-format")
(synopsis "Interface to the Format module")
(description "Easy-format is a high-level and functional interface to the