summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-09-21 20:32:27 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-09-27 21:26:00 +0200
commitbf7bc0d6bb8e549f1b05dae3fe4f325311db8310 (patch)
tree906ce5205a5345797f574bb2cb9a5fcbe04c44a4 /gnu/packages/ocaml.scm
parentcb1e0cfc2f32e6811da588231497d896491ceabb (diff)
downloadpatches-bf7bc0d6bb8e549f1b05dae3fe4f325311db8310.tar
patches-bf7bc0d6bb8e549f1b05dae3fe4f325311db8310.tar.gz
gnu: Add ocaml-ezjsonm.
* gnu/packages/ocaml.scm (ocaml-ezjsonm): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 700c5698ed..f3ebb28542 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3197,6 +3197,36 @@ writing to these structures, and they are accessed via the Bigarray module.")
(description "Hex is a minimal library providing hexadecimal converters.")
(license license:isc)))
+(define-public ocaml-ezjsonm
+ (package
+ (name "ocaml-ezjsonm")
+ (version "0.4.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mirage/ezjsonm/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1kag0z2xlk4rw73a240dmkxh9rj6psxxcxkm7d7z0rrj6hzjajgq"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("alcotest" ,ocaml-alcotest)))
+ (propagated-inputs
+ `(("hex" ,ocaml-hex)
+ ("jsonm" ,ocaml-jsonm)
+ ("lwt" ,ocaml-lwt)
+ ("sexplib" ,ocaml-sexplib)))
+ (arguments
+ `(#:configure-flags (list "--enable-lwt")))
+ (home-page "https://github.com/mirage/ezjsonm/")
+ (synopsis "Read and write JSON data")
+ (description "Ezjsonm provides more convenient (but far less flexible) input
+and output functions that go to and from [string] values than jsonm. This avoids
+the need to write signal code, which is useful for quick scripts that manipulate
+JSON.")
+ (license license:isc)))
+
(define-public coq-flocq
(package
(name "coq-flocq")