summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
committerMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
commit647888845c0d7b9ea1b51a3e3492d4d2382f4468 (patch)
treebe34c5ec88db452c63253dc4a15f9f4cf199b1e6 /gnu/packages/ocaml.scm
parentfe15613cdf8623574ce64c05416dd3fab41eef86 (diff)
parentc657716ede8932da356635802534aa13205a6ecd (diff)
downloadpatches-647888845c0d7b9ea1b51a3e3492d4d2382f4468.tar
patches-647888845c0d7b9ea1b51a3e3492d4d2382f4468.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 25ef8ccad0..5f67aa62aa 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3759,7 +3759,7 @@ sensitive completion, colors, and more.")
(delete 'configure))))
(inputs
`(("topkg" ,ocaml-topkg)
- ("opam", opam)))
+ ("opam" ,opam)))
(synopsis "Various signed and unsigned integer types for OCaml")
(description "The ocaml-integers library provides a number of 8-, 16-, 32-
and 64-bit signed and unsigned integer types, together with aliases such as
@@ -3793,7 +3793,7 @@ long and size_t whose sizes depend on the host platform.")
("integers" ,ocaml-integers)
("lwt" ,ocaml-lwt)
("topkg" ,ocaml-topkg)
- ("opam", opam)))
+ ("opam" ,opam)))
(synopsis "Library for binding to C libraries using pure OCaml")
(description "Ctypes is a library for binding to C libraries using pure
OCaml. The primary aim is to make writing C extensions as straightforward as
@@ -3826,7 +3826,7 @@ without writing or generating any C!")
(delete 'configure))))
(inputs
`(("topkg" ,ocaml-topkg)
- ("opam", opam)))
+ ("opam" ,opam)))
(native-inputs
`(("astring" ,ocaml-astring)))
(synopsis "OCamlbuild plugin for C stubs")