summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-28 15:35:28 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-06-06 21:10:06 +0200
commit61bafd44775c864af1bbea293cbd78ec59d9112e (patch)
tree3f589082dbf7e09ba95e2bbf22f311b3afc45ad6 /gnu/packages/ocaml.scm
parent0090b89564a869c6b25cf2b5e4b5cfafa38d5d55 (diff)
downloadpatches-61bafd44775c864af1bbea293cbd78ec59d9112e.tar
patches-61bafd44775c864af1bbea293cbd78ec59d9112e.tar.gz
gnu: Add ocaml-hex.
* gnu/packages/ocaml.scm (ocaml-hex): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3ee90aa06d..e205138a3a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3130,3 +3130,22 @@ big- and little-endian, with their unsafe counter-parts.")
to access C-like structures directly from OCaml. It supports both reading and
writing to these structures, and they are accessed via the Bigarray module.")
(license license:isc)))
+
+(define-public ocaml-hex
+ (package
+ (name "ocaml-hex")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mirage/ocaml-hex/"
+ "archive/" version ".tar.gz"))
+ (sha256
+ (base32
+ "0s63g0b8gfv2xm6fv6xg7bva8h76b5pcjb0zw3f8cygs0lq9072v"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system ocaml-build-system)
+ (propagated-inputs `(("cstruct" ,ocaml-cstruct)))
+ (home-page "https://github.com/mirage/ocaml-hex/")
+ (synopsis "Minimal library providing hexadecimal converters")
+ (description "Hex is a minimal library providing hexadecimal converters.")
+ (license license:isc)))