summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-21 15:54:04 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-22 10:20:50 +0200
commit07b4cd3a48022a472c90ec46f2e8b08d9cc8fc3e (patch)
tree6a5de4196555989ddddbc652701ca02d728d2d37 /gnu/packages/ocaml.scm
parent3d679ab1e5f469bf057402ef11d3fe4b3a20cf41 (diff)
downloadpatches-07b4cd3a48022a472c90ec46f2e8b08d9cc8fc3e.tar
patches-07b4cd3a48022a472c90ec46f2e8b08d9cc8fc3e.tar.gz
gnu: camlp5: install META file.
* gnu/packages/ocaml.scm (camlp5) [phases]: New install-meta phase.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index aa2f006674..40d42a5d49 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -401,7 +401,12 @@ syntax of OCaml.")
(lambda _
(zero? (system* "make" "-j" (number->string
(parallel-job-count))
- "world.opt")))))))
+ "world.opt"))))
+ ;; Required for findlib to find camlp5's libraries
+ (add-after 'install 'install-meta
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "etc/META" (string-append (assoc-ref outputs "out")
+ "/lib/ocaml/camlp5/")))))))
(home-page "http://camlp5.gforge.inria.fr/")
(synopsis "Pre-processor Pretty Printer for OCaml")
(description