summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-09-21 20:46:37 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-09-27 21:26:16 +0200
commit8a238180fd6d2919fb88c378a9852189661a22c9 (patch)
tree6990753a756c116166ed2594a87cc65a708face1 /gnu/packages/ocaml.scm
parent88b1533c27cdfca98556e6ccb4aff3ce5346ad3c (diff)
downloadpatches-8a238180fd6d2919fb88c378a9852189661a22c9.tar
patches-8a238180fd6d2919fb88c378a9852189661a22c9.tar.gz
gnu: Add ocaml-graph.
* gnu/packages/ocaml.scm (ocaml-graph): New variable. * gnu/packages/patches/ocaml-graph-honor-source-date-epoch.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f49deb67a4..52294d10da 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3391,6 +3391,33 @@ unique identifiers (UUIDs) version 3, 5 (named based with MD5, SHA-1 hashing)
and 4 (random based) according to RFC 4122.")
(license license:isc)))
+(define-public ocaml-graph
+ (package
+ (name "ocaml-graph")
+ (version "1.8.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://ocamlgraph.lri.fr/download/"
+ "ocamlgraph-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1845r537swjil2fcj7lgbibc2zybfwqqasrd2s7bncajs83cl1nz"))
+ (patches (search-patches "ocaml-graph-honor-source-date-epoch.patch"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:install-target "install-findlib"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-shell
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CONFIG_SHELL" (string-append (assoc-ref inputs "bash")
+ "/bin/sh")))))))
+ (inputs `(("lablgtk" ,lablgtk)))
+ (home-page "http://ocamlgraph.lri.fr/")
+ (synopsis "Graph library for OCaml")
+ (description "OCamlgraph is a generic graph library for OCaml.")
+ (license license:lgpl2.1)))
+
(define-public coq-flocq
(package
(name "coq-flocq")