summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-11-19 23:28:16 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-12-18 22:16:48 +0100
commitf880b03bcab3bbc137e37fef01da9c65e2dfd078 (patch)
tree4e9a369db7fe8c3836367c87718fa81ec4443c38 /gnu/packages/ocaml.scm
parentf93246a541287aca149ceaa5dd7d4b60a5ee4496 (diff)
downloadpatches-f880b03bcab3bbc137e37fef01da9c65e2dfd078.tar
patches-f880b03bcab3bbc137e37fef01da9c65e2dfd078.tar.gz
gnu: ocaml-lwt: Use dune-build-system.
* gnu/packages/ocaml.scm (ocaml-lwt): Use dune-build-system.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 93d9cf8a27..d8e50d57d7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2161,26 +2161,18 @@ through Transport Layer Security (@dfn{TLS}) encrypted connections.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256 (base32
"0mhh019bjkg5xfvpy1pxs4xdxb759fyydmgb6l4j0qww1qgr8klp"))))
- (build-system ocaml-build-system)
+ (build-system dune-build-system)
(arguments
`(#:tests? #f; require lwt_ppx
+ #:jbuild? #t
#:phases
(modify-phases %standard-phases
- (replace 'configure
+ (add-before 'build 'configure
(lambda _
(invoke "ocaml" "src/util/configure.ml" "-use-libev" "true")
- #t))
- (replace 'build
- (lambda _
- (invoke "jbuilder" "build" "@install")
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "jbuilder" "install" "--prefix" (assoc-ref outputs "out"))
#t)))))
(native-inputs
- `(("dune" ,dune)
- ("ocaml-cppo" ,ocaml-cppo)
+ `(("ocaml-cppo" ,ocaml-cppo)
("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
("pkg-config" ,pkg-config)
("ppx-tools-versioned" ,ocaml-ppx-tools-versioned)))