summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-09-21 20:33:33 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-09-27 21:26:05 +0200
commit3dabefeef4aab9a0c0dc69e30bbbdd0e2ff15059 (patch)
tree5789a5b91b61743af6ed2dcbca26116d247613d6 /gnu/packages/ocaml.scm
parentbf7bc0d6bb8e549f1b05dae3fe4f325311db8310 (diff)
downloadpatches-3dabefeef4aab9a0c0dc69e30bbbdd0e2ff15059.tar
patches-3dabefeef4aab9a0c0dc69e30bbbdd0e2ff15059.tar.gz
gnu: Add ocaml-uri.
* gnu/packages/ocaml.scm (ocaml-uri): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f3ebb28542..b4b4f2333b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3227,6 +3227,32 @@ the need to write signal code, which is useful for quick scripts that manipulate
JSON.")
(license license:isc)))
+(define-public ocaml-uri
+ (package
+ (name "ocaml-uri")
+ (version "1.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mirage/ocaml-uri/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "02bzrag79prx261rxf9mlak749pwf4flpfl8p012x1xznv9m0clc"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("ounit" ,ocaml-ounit)))
+ (propagated-inputs
+ `(("ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+ ("re" ,ocaml-re)
+ ("ppx-deriving" ,ocaml-ppx-deriving)
+ ("sexplib" ,ocaml-sexplib)
+ ("stringext" ,ocaml-stringext)))
+ (home-page "https://github.com/mirage/ocaml-uri")
+ (synopsis "RFC3986 URI/URL parsing library")
+ (description "OCaml-uri is a library for parsing URI/URL in the RFC3986 format.")
+ (license license:isc)))
+
(define-public coq-flocq
(package
(name "coq-flocq")