summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-05-14 20:37:05 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-05-14 21:05:14 +0200
commit70a5701141a50847c15a87a23c8d3a5a03dc63a2 (patch)
tree7aa00cdaa6accfe83b67ec98ce35468252ca94da /gnu/packages/ocaml.scm
parentfbf786bd1d345794dfc93f28beff5efc3dd1786e (diff)
downloadpatches-70a5701141a50847c15a87a23c8d3a5a03dc63a2.tar
patches-70a5701141a50847c15a87a23c8d3a5a03dc63a2.tar.gz
gnu: ocaml-ocb-stubblr: Fix build failures using it.
* gnu/packages/ocaml.scm (ocaml-ocb-stubblr)[arguments]: Add a phase to fix guix-specific issues.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a4d5ede416..638a0437cc 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3153,7 +3153,15 @@ without writing or generating any C!")
`(#:build-flags (list "build" "--tests" "true")
#:phases
(modify-phases %standard-phases
- (delete 'configure))))
+ (delete 'configure)
+ (add-before 'build 'fix-for-guix
+ (lambda _
+ (substitute* "src/ocb_stubblr.ml"
+ ;; Do not fail when opam is not present or initialized
+ (("error_msgf \"error running opam\"") "\"\"")
+ ;; Guix doesn't have cc, but it has gcc
+ (("\"cc\"") "\"gcc\""))
+ #t)))))
(inputs
`(("topkg" ,ocaml-topkg)
("opam" ,opam)))