summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-28 15:27:17 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-06-06 21:09:57 +0200
commit84470902dcb273681e927abd304f74a8fb5c75b1 (patch)
treecb3ecda6bf5979ccd286e20a25f178e90642e54b /gnu/packages/ocaml.scm
parentd7f6d048b116204f849361ef97ca5502c55fa92b (diff)
downloadpatches-84470902dcb273681e927abd304f74a8fb5c75b1.tar
patches-84470902dcb273681e927abd304f74a8fb5c75b1.tar.gz
gnu: Add ocaml-async.
* gnu/packages/ocaml.scm (ocaml-async): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index aa28320440..5acf06d767 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3045,3 +3045,23 @@ standard library that was developed by Jane Street.")
(description "Async_extra provides additional functionnalities for the
async library.")
(license license:asl2.0)))
+
+(define-public ocaml-async
+ (package
+ (name "ocaml-async")
+ (version "113.33.03")
+ (source (janestreet-origin "async" version
+ "0210fyhcs12kpmmd26015bgivkfd2wqkyn3c5wd7688d0f872y25"))
+ (native-inputs
+ `(("oasis" ,ocaml-oasis)
+ ("js-build-tools" ,ocaml-js-build-tools)
+ ("ppx-jane" ,ocaml-ppx-jane)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("async-extra" ,ocaml-async-extra)))
+ (build-system ocaml-build-system)
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/async")
+ (synopsis "Monadic concurrency library")
+ (description "Async is a library for concurrent programming in OCaml.")
+ (license license:asl2.0)))