summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-28 15:16:28 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-06-06 21:09:48 +0200
commit4a5fd872032f8ed4c576fa8f04984b9fea012b9e (patch)
treedb9e9e8e292fa2c926e3aad2b170fad2ce2cbf7a /gnu/packages/ocaml.scm
parentcf28a731c63f3985929b377e8647808e62daaf40 (diff)
downloadpatches-4a5fd872032f8ed4c576fa8f04984b9fea012b9e.tar
patches-4a5fd872032f8ed4c576fa8f04984b9fea012b9e.tar.gz
gnu: Add ocaml-core.
* gnu/packages/ocaml.scm (ocaml-core): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f360e7d1f0..1a70b67bfb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2980,3 +2980,24 @@ the full Core is not available, such as in Javascript.")
(description "Async_rpc_kernel is the platform-independent core of
the Async RPC library.")
(license license:asl2.0)))
+
+(define-public ocaml-core
+ (package
+ (name "ocaml-core")
+ (version "113.33.03")
+ (source (janestreet-origin "core" version
+ "1znll157qg56g9d3247fjibv1hxv3r9wxgr4nhy19j2vzdh6a268"))
+ (native-inputs
+ `(("oasis" ,ocaml-oasis)
+ ("js-build-tools" ,ocaml-js-build-tools)
+ ("ppx-jane" ,ocaml-ppx-jane)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("core-kernel" ,ocaml-core-kernel)))
+ (build-system ocaml-build-system)
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/core/")
+ (synopsis "Alternative to OCaml's standard library")
+ (description "The Core suite of libraries is an alternative to OCaml's
+standard library that was developed by Jane Street.")
+ (license license:asl2.0)))