summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-09-21 20:51:14 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-09-27 21:26:24 +0200
commit408091d5a58801f88f8a5269387ce5efa701508b (patch)
tree338d3a66232f0aeec70cfe51a586b905b965cea4 /gnu/packages/ocaml.scm
parentcd1562ef8ec877ebe02848a2f9a2c73589f78a36 (diff)
downloadpatches-408091d5a58801f88f8a5269387ce5efa701508b.tar
patches-408091d5a58801f88f8a5269387ce5efa701508b.tar.gz
gnu: Add ocaml-camomile.
* gnu/packages/ocaml.scm (ocaml-camomile): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8151044c5b..aa2f006674 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3520,6 +3520,34 @@ of libraries, plugins, and frontends. The libraries provide code reusability,
the plugins facilitate extensibility, and the frontends serve as entry points.")
(license license:expat)))
+(define-public ocaml-camomile
+ (package
+ (name "ocaml-camomile")
+ (version "0.8.5")
+ (home-page "https://github.com/yoriyuki/Camomile")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append home-page "/releases/download/rel-" version
+ "/camomile-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "003ikpvpaliy5hblhckfmln34zqz0mk3y2m1fqvbjngh3h2np045"))))
+ (build-system ocaml-build-system)
+ (native-inputs `(("camlp4" ,camlp4)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-bin/sh
+ (lambda _
+ (setenv "CONFIG_SHELL" (which "bash")))))))
+ (synopsis "Comprehensive Unicode library")
+ (description "Camomile is a Unicode library for OCaml. Camomile provides
+Unicode character type, UTF-8, UTF-16, UTF-32 strings, conversion to/from about
+200 encodings, collation and locale-sensitive case mappings, and more. The
+library is currently designed for Unicode Standard 3.2.")
+ ;; with an exception for linked libraries to use a different license
+ (license license:lgpl2.0+)))
+
(define-public coq-flocq
(package
(name "coq-flocq")