summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-09-21 20:35:17 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-09-27 21:26:10 +0200
commitb5c0217c719b87ba21abc3910e1069e62590a070 (patch)
tree866de81546a90fd2f3a6739c7b92e6e2864acdfa /gnu/packages/ocaml.scm
parent6134aeb9ab631744f397ed2fc28f927563865291 (diff)
downloadpatches-b5c0217c719b87ba21abc3910e1069e62590a070.tar
patches-b5c0217c719b87ba21abc3910e1069e62590a070.tar.gz
gnu: Add ocaml-optcomp.
* gnu/packages/ocaml.scm (ocaml-optcomp): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 35a5a10e4e..4cb66bd2be 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3276,6 +3276,33 @@ JSON.")
Format module of the OCaml standard library.")
(license license:bsd-3)))
+(define-public optcomp
+ (package
+ (name "optcomp")
+ (version "1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/diml/optcomp/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0hhhb2gisah1h22zlg5iszbgqxdd7x85cwd57bd4mfkx9l7dh8jh"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:use-make? #t
+ #:make-flags
+ (list (string-append "BUILDFLAGS=\"-cflags -I,"
+ (assoc-ref %build-inputs "camlp4")
+ "/lib/ocaml/site-lib/camlp4/Camlp4Parsers\""))))
+ (native-inputs `(("camlp4" ,camlp4)))
+ (propagated-inputs `(("camlp4" ,camlp4)))
+ (home-page "https://github.com/diml/optcomp")
+ (synopsis "Optional compilation for OCaml")
+ (description "Optcomp provides an optional compilation facility with
+cpp-like directives.")
+ (license license:bsd-3)))
+
(define-public coq-flocq
(package
(name "coq-flocq")