summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-11-27 21:41:09 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-11-30 15:50:30 +0100
commit05fe0a587a9d470c7bd3e66ac2178cf3389dbd37 (patch)
treeb646cb951c2b32b37d157b9309709de773162593 /gnu/packages/ocaml.scm
parent98a468ffd29252e2b08f53b7e115b8a3e0d1df15 (diff)
downloadpatches-05fe0a587a9d470c7bd3e66ac2178cf3389dbd37.tar
patches-05fe0a587a9d470c7bd3e66ac2178cf3389dbd37.tar.gz
gnu: ocaml-piqilib: Update to 0.6.15.
* gnu/packages/ocaml.scm (ocaml-piqilib): Update to 0.6.15. [source]: Remove patch. [native-inputs]: Remove camlp4. [propagated-inputs]: Replace ulex with sedlex. * gnu/packages/patches/ocaml-piqilib-Update-base64.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 21ed1f167a..663c385d95 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2821,7 +2821,7 @@ Format module of the OCaml standard library.")
(define-public ocaml-piqilib
(package
(name "ocaml-piqilib")
- (version "0.6.14")
+ (version "0.6.15")
(source
(origin
(method git-fetch)
@@ -2830,9 +2830,7 @@ Format module of the OCaml standard library.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0lyqllmfsxmwlg7qidy92kvxi9n39lvachmydcyi81f8p07ykd2d"))
- (patches
- (search-patches "ocaml-piqilib-Update-base64.patch"))))
+ (base32 "0v04hs85xv6d4ysqxyv1dik34dx49yab9shpi4x7iv19qlzl7csb"))))
(build-system ocaml-build-system)
(arguments
`(#:phases
@@ -2868,13 +2866,12 @@ Format module of the OCaml standard library.")
(string-append stubs "/dllpiqilib_stubs.so"))
#t))))))
(native-inputs
- `(("which" ,which)
- ("camlp4" ,camlp4)))
+ `(("which" ,which)))
(propagated-inputs
- `(("xmlm" ,ocaml-xmlm)
- ("ulex" ,ocaml-ulex)
- ("easy-format" ,ocaml-easy-format)
- ("base64" ,ocaml-base64)))
+ `(("ocaml-xmlm" ,ocaml-xmlm)
+ ("ocaml-sedlex" ,ocaml-sedlex)
+ ("ocaml-easy-format" ,ocaml-easy-format)
+ ("ocaml-base64" ,ocaml-base64)))
(home-page "http://piqi.org")
(synopsis "Data serialization and conversion library")
(description "Piqilib is the common library used by the piqi command-line