summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:35:24 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:34:02 +0100
commit6018802d9cea508cd7213db5da609c4f4158dd32 (patch)
treea70a3f237711f6c22f83e7b421a5575ec6e1d89b /gnu/packages/ocaml.scm
parent1365ae47d1668f0c2c7d619bc1d454a204269f0e (diff)
downloadpatches-6018802d9cea508cd7213db5da609c4f4158dd32.tar
patches-6018802d9cea508cd7213db5da609c4f4158dd32.tar.gz
gnu: Add ocaml-ppx-fail.
* gnu/packages/ocaml.scm (ocaml-ppx-fail): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6fbe762b6c..f750843fa6 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5693,3 +5693,28 @@ size, the version of the compiler, ...")
(description "A ppx rewriter for monadic and applicative let bindings,
match expressions, and if expressions.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-fail
+ (package
+ (name "ocaml-ppx-fail")
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+ (version-major+minor version)
+ "/files/ppx_fail-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "07plqsvljiwvngggfypwq55g46s5my55y45mvlmalrxyppzr03s8"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-ppx-here" ,ocaml-ppx-here)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_fail")))
+ (home-page "https://github.com/janestreet/ppx_fail")
+ (synopsis "Add location to calls to failwiths")
+ (description "Syntax extension that makes [failwiths] always include a
+position.")
+ (license license:asl2.0)))